summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-19 12:09:43 -0800
committerAlan Coopersmith <alan.coopersmith@oracle.com>2022-11-19 12:09:43 -0800
commit332394278b7110a774b5277bb3cfc58c42cd888c (patch)
tree2fbfedf4feac3e71a0f7ee0c743f43d3d65cb765 /configure.ac
parent64fc7592fd27bbee300085773247dd1737a5af1b (diff)
XFixesCloseDisplay: Mark codes as unused
Quiets clang warning: Xfixes.c:206:46: warning: unused parameter 'codes' [-Wunused-parameter] XFixesCloseDisplay (Display *dpy, XExtCodes *codes) ^ Raises minimum required version of xproto to 7.0.22 (released June 2011) for the definition of _X_UNUSED Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index dbfc90b..8c18026 100644
--- a/configure.ac
+++ b/configure.ac
@@ -55,7 +55,8 @@ FIXESEXT_VERSION=[`echo $VERSION | sed 's/^\([0-9][0-9]*\.[0-9][0-9]*\).*$/\1/'`
AC_SUBST(FIXESEXT_VERSION)
# Obtain compiler/linker options for dependencies
-PKG_CHECK_MODULES(FIXESEXT, xproto [fixesproto >= $FIXESEXT_VERSION] xextproto [x11 >= 1.6])
+PKG_CHECK_MODULES(FIXESEXT,
+ [xproto >= 7.0.22] [fixesproto >= $FIXESEXT_VERSION] xextproto [x11 >= 1.6])
AC_CONFIG_FILES([Makefile