summaryrefslogtreecommitdiff
path: root/test/utils/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/utils/Makefile.am')
-rw-r--r--test/utils/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/test/utils/Makefile.am b/test/utils/Makefile.am
new file mode 100644
index 0000000..03398b6
--- /dev/null
+++ b/test/utils/Makefile.am
@@ -0,0 +1,35 @@
+#
+# Copyright (c) 2015, Oracle and/or its affiliates. All rights reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+#
+
+noinst_PROGRAMS = lsfontdir
+
+EXTRA_DIST = README
+
+AM_CPPFLAGS = -I$(top_srcdir)/include
+AM_CFLAGS = $(XFONT_CFLAGS) $(OS_CFLAGS) $(CWARNFLAGS)
+
+LDADD = $(top_builddir)/src/libXfont.la
+
+UTIL_SRCS = font-test-utils.c font-test-utils.h
+
+lsfontdir_SOURCES = lsfontdir.c $(UTIL_SRCS)