summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDaniel Stone <daniel@fooishbar.org>2006-07-18 11:39:16 -0400
committerDaniel Stone <daniels@endtroducing.fooishbar.org>2006-07-18 11:39:16 -0400
commit93d3c2c45ccd9a806342746c4df33c684a284dd6 (patch)
tree049eb0517dda1482d48d052e37f2e97e0ac2d556 /Makefile.am
parent8f0d3c6d1f64fdc3b20d0beb831fa457214d5188 (diff)
remove ChangeLog, add dist hook
Remove ChangeLog from the tree, and add a git dist hook to generate it automatically.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 059fffc..48b6eea 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,4 +7,13 @@ SUBDIRS = src man
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xi.pc
-EXTRA_DIST = xi.pc.in autogen.sh
+EXTRA_DIST = xi.pc.in autogen.sh ChangeLog
+
+CLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ GIT_DIR=${srcdir}/.git git-log > ChangeLog
+
+dist-hook: ChangeLog