summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-05-15 14:16:31 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-05-18 10:53:35 +1000
commit615545f9cba36ab7732d2325970a7c84b2fa6e8c (patch)
tree925b1d6ee89ae892c1f5ccc3d73cd86c39dd64ed /configure.ac
parent9966ab40b850c780e439f86e165188919f884b64 (diff)
Switch man pages to asciidoc.
The docbook xml is unreadable and unwritable. Switch everything to asciidoc, at least thay we we can write man pages without losing sanity. asciidoc seems to have some issues with __libmansuffix__, so instead we just use libmansuffix (without underscores). The current asciidoc version is buggy for multiple man targets (more than one man page in a single file), so stick a big warning into configure that a patch is required to the the right asciidoc->docbook conversion. Many thanks to Dan Nicholson for the Makefile.am. Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac18
1 files changed, 14 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index f4d0f3b..38ddedc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -24,13 +24,23 @@ XI_CFLAGS="$CWARNFLAGS $XI_CFLAGS"
AC_SUBST(XI_CFLAGS)
AC_SUBST(XI_LIBS)
-# Check for xmlto for man page conversion
+# Check for xmlto and asciidoc for man page conversion
# (only needed by people building tarballs)
AC_ARG_VAR([XMLTO], [Path to xmlto command])
AC_PATH_PROG([XMLTO], [xmlto])
-AM_CONDITIONAL([HAVE_XMLTO], [test "x$XMLTO" != "x"])
-if test "x$XMLTO" = "x"; then
- AC_MSG_WARN([xmlto not found - cannot create man pages without it])
+AC_ARG_VAR([ASCIIDOC], [Path to asciidoc command])
+AC_PATH_PROG([ASCIIDOC], [asciidoc])
+AM_CONDITIONAL([HAVE_DOCTOOLS], [test "x$XMLTO" != "x" && test "x$ASCIIDOC" != "x"])
+if test "x$XMLTO" = "x" || test "x$ASCIIDOC" = "x"; then
+ AC_MSG_WARN([xmlto or asciidoc not found - cannot create man pages without it])
+else
+ AC_MSG_WARN([
+ *********************************************************
+ xmlto and asciidoc found. I will be building man
+ pages. Your asciidoc may not support multiple docbook
+ targets and building the man pages may fail. See
+ http://hg.sharesource.org/asciidoc/raw-rev/fc5a653a30a3
+ *********************************************************])
fi
XORG_CHECK_MALLOC_ZERO