summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter.hutterer@who-t.net>2009-05-14 16:26:17 +1000
committerPeter Hutterer <peter.hutterer@who-t.net>2009-05-14 16:26:52 +1000
commit3017a5124fe98eb0d1f0e4d0bdce35df06ea751b (patch)
tree76588fba09476ef4fdc4afcb9f162a35a4a44384 /man/Makefile.am
parentea377ea55b2014310fb0777e41ae7044396e25a3 (diff)
Update man pages for XI2.
Shuffling device properties up before all XI2 calls and adding all XI2 calls (bar device property calls). Needs proofreading.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am33
1 files changed, 22 insertions, 11 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 0942146..8b40787 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -30,6 +30,26 @@ LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
libman_xml = XI.xml
+XI2_manpages= \
+ XIQueryPointer.man \
+ XIWarpPointer.man \
+ XIDefineCursor.man \
+ XIUndefineCursor.man \
+ XIChangeHierarchy.man \
+ XISelectEvents.man \
+ XISetClientPointer.man \
+ XIGetClientPointer.man \
+ XIQueryVersion.man \
+ XISetFocus.man \
+ XIGetFocus.man \
+ XIGrabDevice.man \
+ XIGrabButton.man \
+ XIGrabKeysym.man \
+ XIUngrabDevice.man \
+ XIUngrabButton.man \
+ XIUngrabKeysym.man
+
+
libman_PRE = \
XAllowDeviceEvents.man \
XChangeKeyboardDevice.man \
@@ -41,10 +61,6 @@ libman_PRE = \
XSetDeviceValuators.man \
XChangeDeviceDontPropagateList.man \
XGetDeviceDontPropagateList.man \
- XChangeDeviceHierarchy.man \
- XDefineDeviceCursor.man \
- XUndefineDeviceCursor.man \
- XExtendedGrabDevice.man \
XGetDeviceControl.man \
XChangeDeviceControl.man \
XGetDeviceKeyMapping.man \
@@ -61,27 +77,22 @@ libman_PRE = \
XUngrabDeviceKey.man \
XGrabDevice.man \
XUngrabDevice.man \
- XiSelectEvent.man \
XListInputDevices.man \
XFreeDeviceList.man \
XOpenDevice.man \
XCloseDevice.man \
- XQueryDevicePointer.man \
- XQueryInputVersion.man \
XGetExtensionVersion.man \
XSelectExtensionEvent.man \
XGetSelectedExtensionEvents.man \
- XSetClientPointer.man \
- XGetClientPointer.man \
XSetDeviceButtonMapping.man \
XGetDeviceButtonMapping.man \
XSetDeviceFocus.man \
XGetDeviceFocus.man \
- XWarpDevicePointer.man \
XListDeviceProperties.man \
XGetDeviceProperty.man \
XChangeDeviceProperty.man \
- XDeleteDeviceProperty.man
+ XDeleteDeviceProperty.man \
+ $(XI2_manpages)
EXTRA_DIST = $(libman_PRE) $(libman_xml) xi.stamp