summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorPeter Hutterer <peter@cs.unisa.edu.au>2008-05-29 12:45:57 +0930
committerPeter Hutterer <peter@cs.unisa.edu.au>2008-05-29 12:46:24 +0930
commit9831db88ee8e69dc6cf8fad0ac83d40bedd5c463 (patch)
tree64eb02e88b0583a3c7e509a65c8b6f13df246586 /man/Makefile.am
parentfd8198513c865f616be8059907550db7f777b089 (diff)
Don't fail man build when missing xmlto.
If xmlto is missing during configure, print out a warning and just do an empty man build with no man pages at all. Better than failing with obscure errors.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 16de126..4a210c1 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -30,6 +30,7 @@ LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
libman_xml = XI.xml
+if HAVE_XMLTO
XI_manpages = \
XAllowDeviceEvents \
XChangeKeyboardDevice \
@@ -83,6 +84,7 @@ XI_manpages = \
XGetDeviceFocus \
XWarpDevicePointer \
XWindowClearAccess
+endif # HAVE_XMLTO
libman_PRE = $(XI_manpages:%=%.man)
@@ -115,7 +117,6 @@ SUFFIXES = .$(LIB_MAN_SUFFIX) .man
dist-hook: $(libman_PRE)
-if HAVE_XMLTO
.PHONY: do_xmlto_stage
$(libman_PRE): do_xmlto_stage
@@ -125,4 +126,3 @@ do_xmlto_stage: $(libman_xml)
for m in $(XI_manpages); do \
mv -f $$m.__libmansuffix__ $$m.man ; \
done
-endif # HAVE_XMLTO