summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am14
1 files changed, 12 insertions, 2 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 9efc88c..c8c7624 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -51,7 +51,9 @@ libman_PRE = \
XSetDeviceButtonMapping.man \
XSetDeviceFocus.man \
XSetDeviceMode.man \
- XSetDeviceValuators.man
+ XSetDeviceValuators.man \
+ XListDeviceProperties.man \
+ XGetDeviceProperty.man
BUILT_SOURCES = shadows.DONE
@@ -89,7 +91,8 @@ all_shadows = \
$(XOpenDevice_shadows) \
$(XSetDeviceButtonMapping_shadows) \
$(XSetDeviceFocus_shadows) \
- $(XSelectExtensionEvent_shadows)
+ $(XSelectExtensionEvent_shadows) \
+ $(XGetDeviceProperty_shadows)
XGetDeviceControl_shadows = \
@@ -134,6 +137,10 @@ XSetDeviceFocus_shadows = \
XSelectExtensionEvent_shadows = \
XGetSelectedExtensionEvents
+XGetDeviceProperty_shadows = \
+ XDeleteDeviceProperty \
+ XChangeDeviceProperty
+
shadows.DONE:
-rm -f $(all_shadows:=.@LIB_MAN_SUFFIX@)
(for i in $(XGetDeviceControl_shadows:=.@LIB_MAN_SUFFIX@) ; do \
@@ -178,3 +185,6 @@ shadows.DONE:
(for i in $(XSelectExtensionEvent_shadows:=.@LIB_MAN_SUFFIX@) ; do \
echo .so man$(LIB_MAN_DIR_SUFFIX)/XSelectExtensionEvent.$(LIB_MAN_SUFFIX) > $$i; \
done)
+ (for i in $(XGetDeviceProperty_shadows:=.@LIB_MAN_SUFFIX@) ; do \
+ echo .so man$(LIB_MAN_DIR_SUFFIX)/XGetDeviceProperty.$(LIB_MAN_SUFFIX) > $$i; \
+ done)