summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGaetan Nadon <memsize@videotron.ca>2010-02-16 10:37:21 -0500
committerGaetan Nadon <memsize@videotron.ca>2010-02-16 12:24:20 -0500
commit74bb9072015b8a785f6b6458ba0605287a1ffcaf (patch)
tree634bf2108a983607bd10d6d723f84cb59f740988 /src/Makefile.am
parent449d22180549d990ad3164c98b22968359b55df2 (diff)
config: move CWARNFLAGS from configure.ac to Makefile.am
Compiler warning flags should be explicitly set in the makefile rather than being merged with other packages compiler flags. Signed-off-by: Gaetan Nadon <memsize@videotron.ca>
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index ab7e778..85b05da 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -11,7 +11,11 @@ libXrandr_la_SOURCES = \
XrrScreen.c
libXrandr_la_LIBADD = @RANDR_LIBS@
-AM_CFLAGS = @RANDR_CFLAGS@ @MALLOC_ZERO_CFLAGS@
+
+AM_CFLAGS = \
+ $(RANDR_CFLAGS) \
+ $(MALLOC_ZERO_CFLAGS) \
+ $(CWARNFLAGS)
INCLUDES = -I$(top_srcdir)/include/X11/extensions