summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2007-01-27 22:26:55 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2007-01-27 22:26:55 -0800
commita5c7d56278e569257d3d64ff7681d0a484a1f817 (patch)
tree69f8338704a8b5fc815a1eeee594ccf4a19baab5 /Makefile.am
parent67772a3f39c5e8c4019336b0bf4d32e70726b0c0 (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f64b433..dcc853e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,6 +1,4 @@
#
-# $Id$
-#
# Copyright © 2003 Keith Packard, Noah Levitt
#
# Permission to use, copy, modify, distribute, and sell this software and its
@@ -29,5 +27,11 @@ AM_CFLAGS = $(XT_CFLAGS) -I$(top_srcdir)/include -I$(top_srcdir)/include/X11 -I$
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = xt.pc
-EXTRA_DIST = xt.pc.in autogen.sh
+EXTRA_DIST = xt.pc.in ChangeLog autogen.sh
+MAINTAINERCLEANFILES=ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+
+dist-hook: ChangeLog