summaryrefslogtreecommitdiff
path: root/usr.sbin/nsd/configure.ac
diff options
context:
space:
mode:
authorStuart Henderson <sthen@cvs.openbsd.org>2015-11-05 21:22:00 +0000
committerStuart Henderson <sthen@cvs.openbsd.org>2015-11-05 21:22:00 +0000
commit826bf9571ac5eb6db80235e3515ca2bf37d88d09 (patch)
tree5a5bacaac23e9da2ebf341b9f07350a600e3a946 /usr.sbin/nsd/configure.ac
parent4b0994c5bf8295e6a924feb909e9c44c1ed16f14 (diff)
merge
Diffstat (limited to 'usr.sbin/nsd/configure.ac')
-rw-r--r--usr.sbin/nsd/configure.ac19
1 files changed, 9 insertions, 10 deletions
diff --git a/usr.sbin/nsd/configure.ac b/usr.sbin/nsd/configure.ac
index 60ea50d2bf2..d559af34d7c 100644
--- a/usr.sbin/nsd/configure.ac
+++ b/usr.sbin/nsd/configure.ac
@@ -4,7 +4,7 @@ dnl
sinclude(acx_nlnetlabs.m4)
-AC_INIT(NSD,4.1.3,nsd-bugs@nlnetlabs.nl)
+AC_INIT(NSD,4.1.6,nsd-bugs@nlnetlabs.nl)
AC_CONFIG_HEADER([config.h])
CFLAGS="$CFLAGS"
@@ -282,6 +282,8 @@ if test "x$CFLAGS" = "x" ; then
# we do not use O3 because it causes miscompilations.
ACX_CHECK_COMPILER_FLAG(O2, [CFLAGS="$CFLAGS -O2"])
ACX_CHECK_FLTO
+ ACX_CHECK_PIE
+ ACX_CHECK_RELRO_NOW
fi
AC_C_CONST
AC_C_INLINE
@@ -502,6 +504,12 @@ AC_CHECK_STRPTIME_WORKS
ACX_CHECK_NONBLOCKING_BROKEN
ACX_MKDIR_ONE_ARG
+# see if reuseport is enabled by default (also a config option).
+# freebsd can compile the option, but it does not work, it works on Linux.
+if test "`uname`" = "Linux"; then
+ AC_DEFINE([REUSEPORT_BY_DEFAULT], 1, [enable reuseport option by default.])
+fi
+
# set -I. and -Isrcdir
if test -n "$CPPFLAGS"; then
CPPFLAGS="$CPPFLAGS -I."
@@ -736,15 +744,6 @@ AC_ARG_WITH([facility],
AC_DEFINE_UNQUOTED([FACILITY], $facility, [Define to the default facility for syslog.])
dnl
-dnl Determine the maximum number of ip-addresses that are allowed
-dnl
-max_ips=32
-AC_ARG_WITH([max_ips],
- AC_HELP_STRING([--with-max-ips=number], [Limit on the number of ip-addresses that may be specified]),
- [max_ips=$withval])
-AC_DEFINE_UNQUOTED([MAX_INTERFACES], $max_ips, [Define to the maximum ip-addresses to serve.])
-
-dnl
dnl Determine the default tcp timeout
dnl
tcp_timeout=120