summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2006-07-13 14:31:20 -0700
committerAlan Coopersmith <alanc@alf.(none)>2006-07-13 14:31:20 -0700
commit33b44547db1b801a520b64dd67c468ab04eaf269 (patch)
tree863c2173a80399de451f2d06048a70cd480b1ec6 /Makefile.am
parent953df72ff3b8ecf8ac3eadc90ddefd6d0ca6b43e (diff)
Replace static ChangeLog with dist-hook to generate from git log
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 87463d9..ea79439 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,4 +22,12 @@
aclocaldir = $(datadir)/aclocal
aclocal_DATA = xorgversion.m4 xorg-macros.m4
-EXTRA_DIST = $(aclocal_DATA)
+EXTRA_DIST = $(aclocal_DATA) ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (cd $(srcdir) && git-log) > ChangeLog
+
+dist-hook: ChangeLog
+