summaryrefslogtreecommitdiff
path: root/app/luit/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2013-07-14 09:21:39 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2013-07-14 09:21:39 +0000
commitb4f39054fecc9c1ed59eb10c005f2af4d127baf6 (patch)
tree3938cfdc87d07bdb85148767a32a91fc29005953 /app/luit/configure.ac
parent3223071b0a0eb39730fc6e4e4e2d1428fdcb0537 (diff)
Don't try to use grantpt() on OpenBSD. It causes crashes.
Problem reported by Jan Stary and Marcus Merighi, analysed by guenther@, configure.ac patch by me.
Diffstat (limited to 'app/luit/configure.ac')
-rw-r--r--app/luit/configure.ac12
1 files changed, 10 insertions, 2 deletions
diff --git a/app/luit/configure.ac b/app/luit/configure.ac
index c214d85c9..8affcc49d 100644
--- a/app/luit/configure.ac
+++ b/app/luit/configure.ac
@@ -38,7 +38,15 @@ AC_CANONICAL_HOST
AC_CHECK_HEADERS([pty.h stropts.h sys/param.h sys/select.h])
-AC_CHECK_FUNCS([select grantpt posix_openpt])
+# grantpt support is broken on OpenBSD
+case $host_os in
+ openbsd*)
+ AC_CHECK_FUNCS([select])
+ ;;
+ *)
+ AC_CHECK_FUNCS([select grantpt posix_openpt])
+ ;;
+esac
AC_ARG_WITH(localealiasfile,
AS_HELP_STRING([--with-localealiasfile=<path>],
@@ -73,7 +81,7 @@ esac
AC_SUBST(OS_CFLAGS)
AC_CHECK_HEADERS([pty.h stropts.h sys/ioctl.h sys/param.h sys/poll.h sys/select.h sys/time.h termios.h])
-AC_CHECK_FUNCS([grantpt putenv select strdup])
+AC_CHECK_FUNCS([putenv select strdup])
if test "x$ac_cv_func_grantpt" != "xyes" ; then
AC_CHECK_LIB(util, openpty, [cf_have_openpty=yes],[cf_have_openpty=no])