summaryrefslogtreecommitdiff
path: root/app/setxkbmap/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-03-08 07:59:24 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-03-08 07:59:24 +0000
commite3a3855ef99aac36d1c9dd930ab403ef96c040d1 (patch)
tree43df73b2e7f865ece0566ba1399277c8243e9f21 /app/setxkbmap/configure.ac
parente4d327ce931c7ff0281739348aa9ca23e109a578 (diff)
add a new build switch 'XENOCARA_USE_XKEYBOARD_CONFIG' to enable
the use of xkeyboard-config xkb definitions instead of the old xkbdata. This will make testing easier. No changes in default builds. ok shadchin@
Diffstat (limited to 'app/setxkbmap/configure.ac')
-rw-r--r--app/setxkbmap/configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/app/setxkbmap/configure.ac b/app/setxkbmap/configure.ac
index adcbc26f1..05fda0125 100644
--- a/app/setxkbmap/configure.ac
+++ b/app/setxkbmap/configure.ac
@@ -45,6 +45,13 @@ AC_ARG_WITH(xkb-config-root,
[XKBCONFIGROOT=${datadir}/X11/xkb])
AC_SUBST([XKBCONFIGROOT])
+AC_ARG_WITH(xkb-default-rules,
+ AC_HELP_STRING([--with-xkb-default-rules=<rules>],
+ [Set default XKB rules (default: xorg)]),
+ [XKBDEFAULTRULES="$withval"],
+ [XKBDEFAULTRULES=xorg])
+AC_SUBST([XKBDEFAULTRULES])
+
# Checks for pkg-config packages
PKG_CHECK_MODULES(SETXKBMAP, xkbfile x11)