summaryrefslogtreecommitdiff
path: root/app/twm/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 18:16:23 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-10-31 18:16:23 +0000
commit769b60f3c05855dd9a3fa5c4289b636c7e8238b2 (patch)
tree1618f2ef189dbcaf459bb47b6f82ec505981a86d /app/twm/configure.ac
parentb860331aa1bb8b68d65512af073ff9a52d0f04f8 (diff)
Update to twm 1.0.5
Diffstat (limited to 'app/twm/configure.ac')
-rw-r--r--app/twm/configure.ac26
1 files changed, 14 insertions, 12 deletions
diff --git a/app/twm/configure.ac b/app/twm/configure.ac
index 7a514d5b3..ef9c4b49b 100644
--- a/app/twm/configure.ac
+++ b/app/twm/configure.ac
@@ -20,28 +20,30 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(twm,[1.0.4], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],twm)
-AM_INIT_AUTOMAKE([dist-bzip2])
+AC_PREREQ([2.60])
+AC_INIT([twm], [1.0.5],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [twm])
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-AC_PROG_CC
-AC_PROG_INSTALL
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
+m4_ifndef([XORG_MACROS_VERSION],
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
+XORG_DEFAULT_OPTIONS
+
AC_PROG_YACC
+AC_PATH_PROG([YACC_INST], $YACC)
+AC_CHECK_FILE([$srcdir/gram.c], [],
+ [test -z "$YACC_INST" && AC_MSG_ERROR([yacc not found - unable to compile gram.y])])
AC_PROG_LEX
-AC_CHECK_FUNC([mkstemp],
- AC_DEFINE(HAS_MKSTEMP,1,[Define to 1 if you have the `mkstemp' function.]))
+AC_CHECK_FUNCS([mkstemp])
# Checks for pkg-config packages
PKG_CHECK_MODULES(TWM, x11 xext xt xmu ice sm)
-AC_SUBST(TWM_CFLAGS)
-AC_SUBST(TWM_LIBS)
-
-XORG_MANPAGE_SECTIONS
-XORG_RELEASE_VERSION
AC_OUTPUT([Makefile
src/Makefile