summaryrefslogtreecommitdiff
path: root/app/xdriinfo/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-11-11 11:06:34 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-11-11 11:06:34 +0000
commitb2be8e1bf7c23ac1bfa9e6e64b1dd8e23cdc01a9 (patch)
treef94152e6fc9235ebd12adb661de4836f469ef44d /app/xdriinfo/configure.ac
parentb32252ac1d50a6f33afb4917cab1104319b12f6a (diff)
Update to xdriinfo 1.0.4
Diffstat (limited to 'app/xdriinfo/configure.ac')
-rw-r--r--app/xdriinfo/configure.ac35
1 files changed, 15 insertions, 20 deletions
diff --git a/app/xdriinfo/configure.ac b/app/xdriinfo/configure.ac
index 4c227b1bc..b6a249d40 100644
--- a/app/xdriinfo/configure.ac
+++ b/app/xdriinfo/configure.ac
@@ -20,37 +20,32 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(xdriinfo, [1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], xdriinfo)
-AM_INIT_AUTOMAKE([dist-bzip2])
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([xdriinfo], [1.0.4],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [xdriinfo])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
-# Require xorg-macros 1.3 or later: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.3 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.3)
-
-AM_CONFIG_HEADER(config.h)
-
-AC_PROG_CC
-AC_PROG_INSTALL
-
-AC_TYPE_SIGNAL
-
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XDRIINFO, xext x11 glproto)
-# libGL depends on libm
-XDRIINFO_LIBS="${XDRIINFO_LIBS} -lm"
-
-AC_SUBST(XDRIINFO_CFLAGS)
-AC_SUBST(XDRIINFO_LIBS)
-
# Checks for non-pkg-config packages (Mesa or vendor OpenGL)
AC_SEARCH_LIBS([glXGetProcAddressARB], [GL], [],
AC_MSG_FAILURE([cannot find GL library - make sure Mesa or other OpenGL package is installed]),
[$XDRIINFO_LIBS])
+# libGL depends on libm
+XDRIINFO_LIBS="${XDRIINFO_LIBS} -lm"
+
AC_OUTPUT([Makefile])