summaryrefslogtreecommitdiff
path: root/doc/xorg-docs/man/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2011-04-24 10:30:45 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2011-04-24 10:30:45 +0000
commitbc3f869925ec95f2fa431f6cf9b687a5349e14bb (patch)
treec12133262a77d99d1e50dad03811d6a4c9d568b8 /doc/xorg-docs/man/Makefile.am
parente92849244470e2aa75e76bbf7cb5066f986b229d (diff)
Update to xorg-docs 1.6.
As with previous version, only manual pages in section 7 are installed for now. More work is needed to be able to format and install the docs that have been converted to docbook xml.
Diffstat (limited to 'doc/xorg-docs/man/Makefile.am')
-rw-r--r--doc/xorg-docs/man/Makefile.am24
1 files changed, 23 insertions, 1 deletions
diff --git a/doc/xorg-docs/man/Makefile.am b/doc/xorg-docs/man/Makefile.am
index 68eda4914..74ad43e43 100644
--- a/doc/xorg-docs/man/Makefile.am
+++ b/doc/xorg-docs/man/Makefile.am
@@ -20,4 +20,26 @@
#
# Process this file with autoconf to create configure.
-SUBDIRS = general
+miscmandir = $(MISC_MAN_DIR)
+
+miscman_PRE = \
+ Consortium.man \
+ Xsecurity.man \
+ Standards.man \
+ X.man \
+ XOrgFoundation.man \
+ XProjectTeam.man
+
+miscman_DATA = $(miscman_PRE:man=@MISC_MAN_SUFFIX@)
+
+EXTRA_DIST = $(miscman_PRE)
+CLEANFILES = $(miscman_DATA)
+SUFFIXES = .$(MISC_MAN_SUFFIX) .man
+
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
+MAN_SUBSTS += -e 's|__datadir__|$(datadir)|g' \
+ -e 's|__libdir__|$(libdir)|g' \
+ -e 's|__sysconfdir__|$(sysconfdir)|g'
+
+.man.$(MISC_MAN_SUFFIX):
+ $(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@