summaryrefslogtreecommitdiff
path: root/driver/xf86-video-imstt/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:06:09 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:06:09 +0000
commit5632259878e5eb2051affab09d149d013df7a0ca (patch)
tree387fcf4ca3659367a8be435ba48ea437c4b57e91 /driver/xf86-video-imstt/src/Makefile.am
parentc93192389bef6d79e2e18cfb36fe4f2691d7c79e (diff)
Importing xf86-video-imstt 1.1.0
Diffstat (limited to 'driver/xf86-video-imstt/src/Makefile.am')
-rw-r--r--driver/xf86-video-imstt/src/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/driver/xf86-video-imstt/src/Makefile.am b/driver/xf86-video-imstt/src/Makefile.am
new file mode 100644
index 000000000..35b17489b
--- /dev/null
+++ b/driver/xf86-video-imstt/src/Makefile.am
@@ -0,0 +1,35 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@
+imstt_drv_la_LTLIBRARIES = imstt_drv.la
+imstt_drv_la_LDFLAGS = -module -avoid-version
+imstt_drv_ladir = @moduledir@/drivers
+
+imstt_drv_la_SOURCES = \
+ imstt_accel.c \
+ imstt_driver.c \
+ imstt.h \
+ imstt_reg.h