summaryrefslogtreecommitdiff
path: root/driver/xf86-video-nv/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-08-22 12:29:28 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-08-22 12:29:28 +0000
commit3ee16a263dc221489e6f26bc32140c5d71c35609 (patch)
tree09fc6b10952722066b05e4cc99b0c1025da3407e /driver/xf86-video-nv/src/Makefile.am
parentf23300683699bc2ce1fa9f0f17cdde28c221d92e (diff)
Update to xf86-video-nv 2.1.18.
Tested at least by krw@, benoit@ and giovanni@.
Diffstat (limited to 'driver/xf86-video-nv/src/Makefile.am')
-rw-r--r--driver/xf86-video-nv/src/Makefile.am23
1 files changed, 1 insertions, 22 deletions
diff --git a/driver/xf86-video-nv/src/Makefile.am b/driver/xf86-video-nv/src/Makefile.am
index 2677d9c70..70e127c3e 100644
--- a/driver/xf86-video-nv/src/Makefile.am
+++ b/driver/xf86-video-nv/src/Makefile.am
@@ -23,7 +23,7 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
-AM_CFLAGS = @XMODES_CFLAGS@ @XORG_CFLAGS@
+AM_CFLAGS = @XORG_CFLAGS@
nv_drv_la_LTLIBRARIES = nv_drv.la
nv_drv_la_LDFLAGS = -module -avoid-version
nv_drv_ladir = @moduledir@/drivers
@@ -82,24 +82,3 @@ g80_sources = \
g80_xaa.c \
g80_xaa.h
-xmode_sources = \
- @parser_dir@/xf86Parser.h \
- @parser_dir@/xf86Optrec.h \
- @modes_dir@/xf86Modes.h \
- @modes_dir@/xf86Modes.c \
- @modes_dir@/xf86cvt.c \
- @modes_dir@/xf86Crtc.h \
- @modes_dir@/xf86Crtc.c \
- @modes_dir@/xf86Cursors.c \
- @modes_dir@/xf86EdidModes.c \
- @modes_dir@/xf86gtf.c \
- @modes_dir@/xf86RandR12.c \
- @modes_dir@/xf86RandR12.h \
- @modes_dir@/xf86Rename.h \
- @modes_dir@/xf86Rotate.c \
- @modes_dir@/xf86DiDGA.c
-
-if BUILD_XMODES
-EXTRA_nv_drv_la_SOURCES = local_xf86Rename.h
-nodist_nv_drv_la_SOURCES = $(xmode_sources)
-endif