summaryrefslogtreecommitdiff
path: root/driver/xf86-video-r128/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2012-09-08 20:47:50 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2012-09-08 20:47:50 +0000
commiteecea31b6dc87300fd264bcd7665f2610f848d59 (patch)
tree49b38c1843bf1c4528a68f94e6742a5cc0e5aee1 /driver/xf86-video-r128/configure.ac
parentff2c3ea9a8bf4733ccf551261f80f4542d5fbe11 (diff)
Update to xf86-video-r128 6.8.4
Diffstat (limited to 'driver/xf86-video-r128/configure.ac')
-rw-r--r--driver/xf86-video-r128/configure.ac20
1 files changed, 19 insertions, 1 deletions
diff --git a/driver/xf86-video-r128/configure.ac b/driver/xf86-video-r128/configure.ac
index ecbe3d36d..e45a40201 100644
--- a/driver/xf86-video-r128/configure.ac
+++ b/driver/xf86-video-r128/configure.ac
@@ -23,7 +23,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xf86-video-r128],
- [6.8.2],
+ [6.8.4],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
[xf86-video-r128])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -117,6 +117,24 @@ AC_CHECK_DECL(XSERVER_LIBPCIACCESS,
[#include "xorg-server.h"])
CPPFLAGS="$SAVE_CPPFLAGS"
+AC_ARG_ENABLE(xaa,
+ AS_HELP_STRING([--enable-xaa],
+ [Enable legacy X Acceleration Architecture (XAA) [default=auto]]),
+ [XAA="$enableval"],
+ [XAA=auto])
+if test "x$XAA" != xno; then
+ save_CFLAGS=$CFLAGS
+ save_CPPFLAGS=$CPPFLAGS
+ CFLAGS=$XORG_CFLAGS
+ CPPFLAGS="$XORG_CFLAGS"
+ AC_CHECK_HEADERS([xaa.h], XAA=yes, XAA=no)
+ CFLAGS=$save_CFLAGS
+ CPPFLAGS=$save_CPPFLAGS
+fi
+AC_MSG_CHECKING([whether to include XAA support])
+AM_CONDITIONAL(XAA, test "x$XAA" = xyes)
+AC_MSG_RESULT([$XAA])
+
AM_CONDITIONAL(USE_EXA, test "x$USE_EXA" = xyes)
if test "x$XSERVER_LIBPCIACCESS" = xyes; then