summaryrefslogtreecommitdiff
path: root/driver/xf86-video-rendition/src/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:10:27 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 20:10:27 +0000
commit40975f985debf42d3a04b105ff6316ee6546c619 (patch)
tree1d448c982171b33e84aed4418ab23288346b856f /driver/xf86-video-rendition/src/Makefile.am
parent2d353c9727ea483a971f991347bc3fe47f26a14d (diff)
Importing xf86-video-rendition 4.1.2
Diffstat (limited to 'driver/xf86-video-rendition/src/Makefile.am')
-rw-r--r--driver/xf86-video-rendition/src/Makefile.am71
1 files changed, 71 insertions, 0 deletions
diff --git a/driver/xf86-video-rendition/src/Makefile.am b/driver/xf86-video-rendition/src/Makefile.am
new file mode 100644
index 000000000..5194089c8
--- /dev/null
+++ b/driver/xf86-video-rendition/src/Makefile.am
@@ -0,0 +1,71 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+# this is obnoxious:
+# -module lets us name the module exactly how we want
+# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
+# _ladir passes a dummy rpath to libtool so the thing will actually link
+# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+AM_CFLAGS = @XORG_CFLAGS@ -DMODULEDIR=\"@moduledir@\"
+rendition_drv_la_LTLIBRARIES = rendition_drv.la
+rendition_drv_la_LDFLAGS = -module -avoid-version
+rendition_drv_ladir = @moduledir@/drivers
+
+rendition_drv_la_SOURCES = \
+ accel.h \
+ accelX.c \
+ cmd2d.h \
+ commonregs.h \
+ cscode.h \
+ hwcursor.c \
+ hwcursor.h \
+ rendition.c \
+ rendition.h \
+ rendition_options.h \
+ rendition_shadow.c \
+ rendition_shadow.h \
+ v1kregs.h \
+ v1krisc.c \
+ v1krisc.h \
+ v2kregs.h \
+ vboard.c \
+ vboard.h \
+ vloaduc.c \
+ vloaduc.h \
+ vmisc.c \
+ vmisc.h \
+ vmodes.c \
+ vmodes.h \
+ vos.h \
+ vramdac.c \
+ vramdac.h \
+ vtypes.h
+
+driverdir = @moduledir@
+dist_driver_DATA = \
+ v10002d.uc \
+ v20002d.uc
+
+EXTRA_DIST = \
+ README.uc \
+ vgafont-std.data \
+ vgafont-vrx.data \
+ vgapalette.data
+