summaryrefslogtreecommitdiff
path: root/driver/xf86-video-s3virge/configure.ac
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2012-09-08 16:08:26 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2012-09-08 16:08:26 +0000
commit581dd7ebfee7a6df24e8ad9e117201006e3a0485 (patch)
tree8c3c5ed3505e175c9aa2ea41e314f1bb861a5117 /driver/xf86-video-s3virge/configure.ac
parent0824b89d056c3a405f921fa02623729773b8efe8 (diff)
Update xf86-video-s3virge to 1.10.6
Diffstat (limited to 'driver/xf86-video-s3virge/configure.ac')
-rw-r--r--driver/xf86-video-s3virge/configure.ac22
1 files changed, 20 insertions, 2 deletions
diff --git a/driver/xf86-video-s3virge/configure.ac b/driver/xf86-video-s3virge/configure.ac
index 45a630f4d..33197dbb3 100644
--- a/driver/xf86-video-s3virge/configure.ac
+++ b/driver/xf86-video-s3virge/configure.ac
@@ -1,4 +1,4 @@
-# Copyright 2005 Adam Jackson.
+\# Copyright 2005 Adam Jackson.
#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
@@ -23,7 +23,7 @@
# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([xf86-video-s3virge],
- [1.10.5],
+ [1.10.6],
[https://bugs.freedesktop.org/enter_bug.cgi?product=xorg],
[xf86-video-s3virge])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -81,6 +81,24 @@ if test "x$XSERVER_LIBPCIACCESS" = xyes; then
fi
AM_CONDITIONAL(XSERVER_LIBPCIACCESS, test "x$XSERVER_LIBPCIACCESS" = xyes)
+AC_ARG_ENABLE(xaa,
+ AS_HELP_STRING([--enable-xaa],
+ [Enable legacy X Acceleration Architecture (XAA) [default=auto]]),
+ [XAA="$enableval"],
+ [XAA=auto])
+if test "x$XAA" != xno; then
+ save_CFLAGS=$CFLAGS
+ save_CPPFLAGS=$CPPFLAGS
+ CFLAGS=$XORG_CFLAGS
+ CPPFLAGS="$XORG_CFLAGS"
+ AC_CHECK_HEADERS([xaa.h], XAA=yes, XAA=no)
+ CFLAGS=$save_CFLAGS
+ CPPFLAGS=$save_CPPFLAGS
+fi
+AC_MSG_CHECKING([whether to include XAA support])
+AM_CONDITIONAL(XAA, test "x$XAA" = xyes)
+AC_MSG_RESULT([$XAA])
+
AC_SUBST([moduledir])
DRIVER_NAME=s3virge