summaryrefslogtreecommitdiff
path: root/driver/xf86-video-wildcatfb/Makefile.am
diff options
context:
space:
mode:
authorMiod Vallat <miod@cvs.openbsd.org>2009-01-01 19:29:23 +0000
committerMiod Vallat <miod@cvs.openbsd.org>2009-01-01 19:29:23 +0000
commit7ab2c4398b690647a7519f1c38744752d5fd607d (patch)
tree771ebfee1f456b59da134517d6d8c11061aa1bf5 /driver/xf86-video-wildcatfb/Makefile.am
parenteba710a9e4a9a4422668c17c1b1ceb7b23c0ee82 (diff)
Simple unaccelerated driver for ifb(4) frame buffer, using a the X11 shadowfb
code to carry changes to both overlay areas. ok matthieu@
Diffstat (limited to 'driver/xf86-video-wildcatfb/Makefile.am')
-rw-r--r--driver/xf86-video-wildcatfb/Makefile.am36
1 files changed, 36 insertions, 0 deletions
diff --git a/driver/xf86-video-wildcatfb/Makefile.am b/driver/xf86-video-wildcatfb/Makefile.am
new file mode 100644
index 000000000..bfcf68d32
--- /dev/null
+++ b/driver/xf86-video-wildcatfb/Makefile.am
@@ -0,0 +1,36 @@
+# Copyright 2005 Adam Jackson.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# ADAM JACKSON BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER
+# IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN
+# CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AUTOMAKE_OPTIONS = foreign
+SUBDIRS = src man
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ ( GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && \
+ mv .changelog.tmp ChangeLog; rm -f .changelog.tmp ) || \
+ ( touch ChangeLog; \
+ echo 'git directory not found: installing possibly empty ChangeLog.' \
+ >&2 )
+
+
+dist-hook: ChangeLog
+
+CLEANFILES= ChangeLog