summaryrefslogtreecommitdiff
path: root/font/daewoo-misc/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 16:00:28 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-26 16:00:28 +0000
commit05af290795fb73a32586aad8eccd8cebb803ad5b (patch)
treefe76d7aeea863abdb28305d19275b2c3aed6e79b /font/daewoo-misc/Makefile.am
parent4cdf4dacccfbc84c99d9a51a9283b23642406072 (diff)
Importing font-daewoo-misc 1.0.0
Diffstat (limited to 'font/daewoo-misc/Makefile.am')
-rw-r--r--font/daewoo-misc/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/font/daewoo-misc/Makefile.am b/font/daewoo-misc/Makefile.am
new file mode 100644
index 000000000..0830e5806
--- /dev/null
+++ b/font/daewoo-misc/Makefile.am
@@ -0,0 +1,49 @@
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software
+# and its documentation for any purpose is hereby granted without
+# fee, provided that the above copyright notice appear in all copies
+# and that both that copyright notice and this permission notice
+# appear in supporting documentation, and that the name of Red Hat
+# not be used in advertising or publicity pertaining to distribution
+# of the software without specific, written prior permission. Red
+# Hat makes no representations about the suitability of this software
+# for any purpose. It is provided "as is" without express or implied
+# warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN
+# NO EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS
+# OF USE, DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT,
+# NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF OR IN
+# CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
+
+FONT_FILES = \
+ hanglg16 \
+ hanglm16 \
+ hanglm24
+
+BDF_FILES = $(FONT_FILES:%=%.bdf)
+PCF_FILES = $(FONT_FILES:%=%.pcf.gz)
+
+SUFFIXES = .bdf .pcf.gz
+
+.bdf.pcf.gz:
+ @rm -f $@
+ $(BDFTOPCF) -t $< | gzip > $@
+
+fontdir = @FONTDIR@
+font_DATA = $(PCF_FILES)
+CLEANFILES = $(font_DATA)
+
+EXTRA_DIST = $(BDF_FILES) autogen.sh
+
+install-data-hook:
+ @rm -f $(DESTDIR)$(fontdir)/fonts.scale
+ $(MKFONTSCALE) $(DESTDIR)$(fontdir)
+ @rm -f $(DESTDIR)$(fontdir)/font.dir
+ $(MKFONTDIR) $(DESTDIR)$(fontdir)
+
+distuninstallcheck:
+ @: