summaryrefslogtreecommitdiff
path: root/lib/fontconfig/fc-arch/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:42:53 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 18:42:53 +0000
commit585da679584ca068252199ad4fec7ee44cde2543 (patch)
tree07b22cf8e06f61ad42abec6e2cd4e3bc1916a7a5 /lib/fontconfig/fc-arch/Makefile.am
parent36af073de3f5895bef731e0a54857f779889848b (diff)
Import fontconfig 2.4.1
Diffstat (limited to 'lib/fontconfig/fc-arch/Makefile.am')
-rw-r--r--lib/fontconfig/fc-arch/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/lib/fontconfig/fc-arch/Makefile.am b/lib/fontconfig/fc-arch/Makefile.am
new file mode 100644
index 000000000..819e37ac9
--- /dev/null
+++ b/lib/fontconfig/fc-arch/Makefile.am
@@ -0,0 +1,57 @@
+#
+# $Id $
+#
+# Copyright © 2003 Keith Packard
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+#
+
+CC = @CC_FOR_BUILD@
+EXEEXT = @EXEEXT_FOR_BUILD@
+LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+
+INCLUDES=-I${top_srcdir}/src -I${top_srcdir} $(FREETYPE_CFLAGS) $(WARN_CFLAGS)
+
+TMPL=fcarch.tmpl.h
+STMPL=${top_srcdir}/fc-arch/fcarch.tmpl.h
+TARG=fcarch.h
+
+ARCHITECTURE=@ARCHITECTURE@
+.PRECIOUS: $(TARG)
+
+noinst_PROGRAMS=fc-arch
+
+noinst_HEADERS=$(TARG)
+
+noinst_MANS=fc-arch.man
+
+EXTRA_DIST=$(TMPL)
+
+$(TARG):fc-arch${EXEEXT} $(STMPL) ${top_srcdir}/src/fcint.h ../config.h
+ rm -f $(TARG)
+ ./fc-arch${EXEEXT} $(ARCHITECTURE) < $(STMPL) > $(TARG)
+
+ALIAS_FILES = fcalias.h fcaliastail.h
+
+BUILT_SOURCES = $(ALIAS_FILES)
+
+$(ALIAS_FILES):
+ touch $(ALIAS_FILES)
+
+CLEANFILES=$(TARG) $(ALIAS_FILES)