summaryrefslogtreecommitdiff
path: root/lib/libXfont/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 17:15:02 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 17:15:02 +0000
commitc7506e39de0a72680c0ee181fa6a5666a460764d (patch)
tree76be900f06bcc96a1ec50df8787af2f4b366de00 /lib/libXfont/Makefile.am
parent3b886ee63fdb7ea8f170a5e212f7a28c81c7a5b3 (diff)
import from X.Org 7.2RC1
Diffstat (limited to 'lib/libXfont/Makefile.am')
-rw-r--r--lib/libXfont/Makefile.am57
1 files changed, 57 insertions, 0 deletions
diff --git a/lib/libXfont/Makefile.am b/lib/libXfont/Makefile.am
new file mode 100644
index 000000000..960f704e9
--- /dev/null
+++ b/lib/libXfont/Makefile.am
@@ -0,0 +1,57 @@
+#
+# $Id: Makefile.am,v 1.1 2006/11/25 17:14:30 matthieu Exp $
+#
+# Copyright © 2003 Keith Packard, Noah Levitt
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Keith Packard not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Keith Packard makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# KEITH PACKARD DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL KEITH PACKARD BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+SUBDIRS=src
+
+libXfontincludedir = $(includedir)/X11/fonts
+libXfontinclude_HEADERS = \
+ include/X11/fonts/bdfint.h \
+ include/X11/fonts/bitmap.h \
+ include/X11/fonts/bufio.h \
+ include/X11/fonts/fntfil.h \
+ include/X11/fonts/fntfilio.h \
+ include/X11/fonts/fntfilst.h \
+ include/X11/fonts/fontconf.h \
+ include/X11/fonts/fontencc.h \
+ include/X11/fonts/fontmisc.h \
+ include/X11/fonts/fontmod.h \
+ include/X11/fonts/fontshow.h \
+ include/X11/fonts/fontutil.h \
+ include/X11/fonts/fontxlfd.h \
+ include/X11/fonts/pcf.h \
+ src/FreeType/ft.h \
+ src/FreeType/ftfuncs.h
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = xfont.pc
+
+EXTRA_DIST = xfont.pc.in autogen.sh include/X11/fonts/fontconf.h.in ChangeLog
+
+.PHONY: ChangeLog
+
+CLEANFILES = ChangeLog
+ChangeLog:
+ git-log > ChangeLog
+
+dist-hook: ChangeLog
+