summaryrefslogtreecommitdiff
path: root/lib/libXmu/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-31 18:29:38 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2009-10-31 18:29:38 +0000
commit25ba41f5fc08813ee339172ef68158f2a433ed59 (patch)
tree07dd5e8dfa60169e4462d5a2d6607427107923db /lib/libXmu/Makefile.am
parentd9b828c2d1e6e4e2ceb750c1b925f0bc551a1443 (diff)
Update to libXmu 1.0.5
Diffstat (limited to 'lib/libXmu/Makefile.am')
-rw-r--r--lib/libXmu/Makefile.am20
1 files changed, 16 insertions, 4 deletions
diff --git a/lib/libXmu/Makefile.am b/lib/libXmu/Makefile.am
index bf630766b..955bcb9e2 100644
--- a/lib/libXmu/Makefile.am
+++ b/lib/libXmu/Makefile.am
@@ -1,5 +1,3 @@
-# $Xorg: Makefile.am,v 1.1.1.1 2006/11/25 17:27:50 matthieu Exp $
-
SUBDIRS = include src
pkgconfigdir = $(libdir)/pkgconfig
@@ -8,5 +6,19 @@ pkgconfig_DATA = xmu.pc xmuu.pc
EXTRA_DIST = \
xmu.pc.in \
xmuu.pc.in \
- autogen.sh \
- include/X11/Xmu/WhitePoint.h
+ include/X11/Xmu/WhitePoint.h \
+ ChangeLog
+MAINTAINERCLEANFILES = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ $(CHANGELOG_CMD)
+
+dist-hook: ChangeLog
+
+if LINT
+# Check source code with tools like lint & sparse
+lint:
+ (cd src && $(MAKE) $(MFLAGS) lint)
+endif LINT