summaryrefslogtreecommitdiff
path: root/lib/libXtst/man/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2007-09-18 21:24:31 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2007-09-18 21:24:31 +0000
commita2a16facfc83e58759cfd0c3722090c2d8bbe2df (patch)
tree4bd77a12c17a58c86577ecd780b9a25d738ec3a0 /lib/libXtst/man/Makefile.am
parent5351fb9a23cb70f05075b4d0a4ab09e6fe9311b5 (diff)
libXtst 1.0.3
Diffstat (limited to 'lib/libXtst/man/Makefile.am')
-rw-r--r--lib/libXtst/man/Makefile.am86
1 files changed, 86 insertions, 0 deletions
diff --git a/lib/libXtst/man/Makefile.am b/lib/libXtst/man/Makefile.am
new file mode 100644
index 000000000..845061f86
--- /dev/null
+++ b/lib/libXtst/man/Makefile.am
@@ -0,0 +1,86 @@
+#
+# Copyright 2007 Sun Microsystems, Inc. All rights reserved.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation.
+#
+# The above copyright notice and this permission notice shall be included
+# in all copies or substantial portions of the Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
+# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
+# IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
+# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
+# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
+# OTHER DEALINGS IN THE SOFTWARE.
+#
+# Except as contained in this notice, the name of the copyright holders shall
+# not be used in advertising or otherwise to promote the sale, use or
+# other dealings in this Software without prior written authorization
+# from the copyright holders.
+#
+
+libmandir = $(LIB_MAN_DIR)
+
+LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
+
+libman_xml = $(srcdir)/XTest.xml
+
+XTest_manpages = \
+ XTestQueryExtension \
+ XTestCompareCursorWithWindow \
+ XTestCompareCurrentCursorWithWindow \
+ XTestFakeKeyEvent \
+ XTestFakeButtonEvent \
+ XTestFakeMotionEvent \
+ XTestFakeRelativeMotionEvent \
+ XTestGrabControl \
+ XTestSetGContextOfGC \
+ XTestSetVisualIDOfVisual \
+ XTestDiscard
+
+libman_PRE = $(XTest_manpages:%=%.man)
+
+EXTRA_DIST = $(libman_PRE) $(libman_xml)
+
+CLEANFILES = $(libman_DATA) $(BUILT_SOURCES)
+
+MAINTAINERCLEANFILES = $(libman_PRE)
+
+libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
+
+SED = sed
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's/__xorgversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
+ -e 's/__xservername__/Xorg/g' \
+ -e 's/__xconfigfile__/xorg.conf/g' \
+ -e 's/__appmansuffix__/$(APP_MAN_SUFFIX)/g' \
+ -e 's/__libmansuffix__/$(LIB_MAN_SUFFIX)/g' \
+ -e 's/__filemansuffix__/$(FILE_MAN_SUFFIX)/g'
+
+SUFFIXES = .$(LIB_MAN_SUFFIX) .man
+
+.man.$(LIB_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+
+# Generate nroff sources from DocBook/xml
+
+dist-hook: $(libman_PRE)
+
+if HAVE_XMLTO
+$(libman_PRE): $(libman_xml)
+ $(XMLTO) man $(libman_xml)
+ for m in $(XTest_manpages); do \
+ mv -f $$m.__libmansuffix__ $$m.man ; \
+ done
+
+endif HAVE_XMLTO