summaryrefslogtreecommitdiff
path: root/lib/mesa/include/meson.build
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2023-01-28 08:15:04 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2023-01-28 08:15:04 +0000
commit1c5c7896c1d54abd25c0f33ca996165b359eecb3 (patch)
treebc5a10bbe89ecd4008a5bed7a029babc992f66b5 /lib/mesa/include/meson.build
parentc55dff45ea3a2c70e45601240b248017acc48198 (diff)
Import Mesa 22.3.4
Diffstat (limited to 'lib/mesa/include/meson.build')
-rw-r--r--lib/mesa/include/meson.build39
1 files changed, 21 insertions, 18 deletions
diff --git a/lib/mesa/include/meson.build b/lib/mesa/include/meson.build
index d1d5787cf..5cfbef5a4 100644
--- a/lib/mesa/include/meson.build
+++ b/lib/mesa/include/meson.build
@@ -90,8 +90,8 @@ endif
# Non-upstream headers
if with_egl
install_headers(
+ 'EGL/eglext_angle.h',
'EGL/eglmesaext.h',
- 'EGL/eglextchromium.h',
subdir : 'EGL',
)
endif
@@ -118,27 +118,30 @@ if with_platform_haiku
)
endif
+opencl_headers = files(
+ 'CL/cl.h',
+ 'CL/cl.hpp',
+ 'CL/cl2.hpp',
+ 'CL/cl_d3d10.h',
+ 'CL/cl_d3d11.h',
+ 'CL/cl_dx9_media_sharing.h',
+ 'CL/cl_dx9_media_sharing_intel.h',
+ 'CL/cl_egl.h',
+ 'CL/cl_ext.h',
+ 'CL/cl_ext_intel.h',
+ 'CL/cl_gl.h',
+ 'CL/cl_gl_ext.h',
+ 'CL/cl_icd.h',
+ 'CL/cl_platform.h',
+ 'CL/cl_va_api_media_sharing_intel.h',
+ 'CL/cl_version.h',
+ 'CL/opencl.h',
+)
# Only install the headers if we are building a stand alone implementation and
# not an ICD enabled implementation
if with_gallium_opencl and not with_opencl_icd
install_headers(
- 'CL/cl.h',
- 'CL/cl.hpp',
- 'CL/cl2.hpp',
- 'CL/cl_d3d10.h',
- 'CL/cl_d3d11.h',
- 'CL/cl_dx9_media_sharing.h',
- 'CL/cl_dx9_media_sharing_intel.h',
- 'CL/cl_egl.h',
- 'CL/cl_ext.h',
- 'CL/cl_ext_intel.h',
- 'CL/cl_gl.h',
- 'CL/cl_gl_ext.h',
- 'CL/cl_icd.h',
- 'CL/cl_platform.h',
- 'CL/cl_va_api_media_sharing_intel.h',
- 'CL/cl_version.h',
- 'CL/opencl.h',
+ opencl_headers,
subdir: 'CL'
)
endif