summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2015-11-22 02:46:45 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2015-11-22 02:46:45 +0000
commit3e40341f9dcd7c1bbc9afb8ddb812304820396cf (patch)
tree274b3f522afe1da16ab2b5347758c908bc23fac4 /lib/mesa/src/gallium/Makefile.am
parent7b644ad52b574bec410d557155d666ac17fdf51a (diff)
import Mesa 11.0.6
Diffstat (limited to 'lib/mesa/src/gallium/Makefile.am')
-rw-r--r--lib/mesa/src/gallium/Makefile.am31
1 files changed, 8 insertions, 23 deletions
diff --git a/lib/mesa/src/gallium/Makefile.am b/lib/mesa/src/gallium/Makefile.am
index 38da63b06..e2c1090aa 100644
--- a/lib/mesa/src/gallium/Makefile.am
+++ b/lib/mesa/src/gallium/Makefile.am
@@ -5,14 +5,12 @@ SUBDIRS =
##
SUBDIRS += auxiliary
-SUBDIRS += auxiliary/pipe-loader
##
## Gallium pipe drivers and their respective winsys'
##
SUBDIRS += \
- drivers/ddebug \
drivers/noop \
drivers/trace \
drivers/rbug
@@ -27,6 +25,11 @@ if HAVE_GALLIUM_I915
SUBDIRS += drivers/i915 winsys/i915/drm
endif
+## ilo/i965
+if HAVE_GALLIUM_ILO
+SUBDIRS += drivers/ilo winsys/intel/drm
+endif
+
## nouveau
if HAVE_GALLIUM_NOUVEAU
SUBDIRS += drivers/nouveau winsys/nouveau/drm
@@ -63,14 +66,6 @@ if NEED_RADEON_DRM_WINSYS
SUBDIRS += winsys/radeon/drm
endif
-if HAVE_GALLIUM_ETNAVIV
-SUBDIRS += drivers/etnaviv winsys/etnaviv/drm
-endif
-
-if HAVE_GALLIUM_IMX
-SUBDIRS += drivers/imx winsys/imx/drm
-endif
-
## swrast/softpipe
if HAVE_GALLIUM_SOFTPIPE
SUBDIRS += drivers/softpipe
@@ -81,20 +76,11 @@ SUBDIRS += drivers/llvmpipe
endif
endif
-if HAVE_GALLIUM_SWR
-SUBDIRS += drivers/swr
-endif
-
## vc4/rpi
if HAVE_GALLIUM_VC4
SUBDIRS += drivers/vc4 winsys/vc4/drm
endif
-## virgl
-if HAVE_GALLIUM_VIRGL
-SUBDIRS += drivers/virgl winsys/virgl/drm winsys/virgl/vtest
-endif
-
## the sw winsys'
SUBDIRS += winsys/sw/null
@@ -106,7 +92,7 @@ if HAVE_DRISW
SUBDIRS += winsys/sw/dri
endif
-if HAVE_DRISW_KMS
+if HAVE_DRI2
SUBDIRS += winsys/sw/kms-dri
endif
@@ -128,8 +114,7 @@ EXTRA_DIST = \
## Gallium state trackers and their users (targets)
##
-## XXX: Rename the conditional once we have a config switch for static/dynamic pipe-drivers
-if HAVE_CLOVER
+if HAVE_LOADER_GALLIUM
SUBDIRS += targets/pipe-loader
endif
@@ -141,7 +126,7 @@ if HAVE_DRICOMMON
SUBDIRS += state_trackers/dri targets/dri
endif
-if HAVE_GALLIUM_XLIB_GLX
+if HAVE_X11_DRIVER
SUBDIRS += state_trackers/glx/xlib targets/libgl-xlib
endif