summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2016-05-29 10:22:51 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2016-05-29 10:22:51 +0000
commitc9223eed3c16cd3e98a8f56dda953d8f299de0e3 (patch)
tree53e2a1c3f13bcf6b4ed201d7bc135e7213c94ebe /lib/mesa/src/gallium/Makefile.am
parent6e8f2d062ab9c198239b9283b2b7ed12f4ea17d8 (diff)
Import Mesa 11.2.2
Diffstat (limited to 'lib/mesa/src/gallium/Makefile.am')
-rw-r--r--lib/mesa/src/gallium/Makefile.am12
1 files changed, 10 insertions, 2 deletions
diff --git a/lib/mesa/src/gallium/Makefile.am b/lib/mesa/src/gallium/Makefile.am
index e2c1090aa..e42a8f177 100644
--- a/lib/mesa/src/gallium/Makefile.am
+++ b/lib/mesa/src/gallium/Makefile.am
@@ -5,12 +5,14 @@ SUBDIRS =
##
SUBDIRS += auxiliary
+SUBDIRS += auxiliary/pipe-loader
##
## Gallium pipe drivers and their respective winsys'
##
SUBDIRS += \
+ drivers/ddebug \
drivers/noop \
drivers/trace \
drivers/rbug
@@ -81,6 +83,11 @@ if HAVE_GALLIUM_VC4
SUBDIRS += drivers/vc4 winsys/vc4/drm
endif
+## virgl
+if HAVE_GALLIUM_VIRGL
+SUBDIRS += drivers/virgl winsys/virgl/drm winsys/virgl/vtest
+endif
+
## the sw winsys'
SUBDIRS += winsys/sw/null
@@ -92,7 +99,7 @@ if HAVE_DRISW
SUBDIRS += winsys/sw/dri
endif
-if HAVE_DRI2
+if HAVE_DRISW_KMS
SUBDIRS += winsys/sw/kms-dri
endif
@@ -114,7 +121,8 @@ EXTRA_DIST = \
## Gallium state trackers and their users (targets)
##
-if HAVE_LOADER_GALLIUM
+## XXX: Rename the conditional once we have a config switch for static/dynamic pipe-drivers
+if HAVE_CLOVER
SUBDIRS += targets/pipe-loader
endif