summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/meson.build
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2019-05-23 05:01:20 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2019-05-23 05:01:20 +0000
commite2a3acb64af2657b1181806818eacad061103c23 (patch)
tree7535f61f2c3f8a69404befb400ecca145be4429c /lib/mesa/src/gallium/meson.build
parent1e3bb66f697283b6bd192f3a000d99d637624079 (diff)
Import Mesa 19.0.5
Diffstat (limited to 'lib/mesa/src/gallium/meson.build')
-rw-r--r--lib/mesa/src/gallium/meson.build23
1 files changed, 9 insertions, 14 deletions
diff --git a/lib/mesa/src/gallium/meson.build b/lib/mesa/src/gallium/meson.build
index 561af9d33..5e311217c 100644
--- a/lib/mesa/src/gallium/meson.build
+++ b/lib/mesa/src/gallium/meson.build
@@ -89,27 +89,22 @@ if with_gallium_vc4
else
driver_vc4 = declare_dependency()
endif
-if with_gallium_pl111
- subdir('winsys/pl111/drm')
-else
- driver_pl111 = declare_dependency()
-endif
-if with_gallium_v3d
- subdir('winsys/v3d/drm')
- subdir('drivers/v3d')
-else
- driver_v3d = declare_dependency()
-endif
if with_gallium_etnaviv
subdir('winsys/etnaviv/drm')
subdir('drivers/etnaviv')
else
driver_etnaviv = declare_dependency()
endif
-if with_gallium_imx
- subdir('winsys/imx/drm')
+if with_gallium_kmsro
+ subdir('winsys/kmsro/drm')
else
- driver_imx = declare_dependency()
+ driver_kmsro = declare_dependency()
+endif
+if with_gallium_v3d
+ subdir('winsys/v3d/drm')
+ subdir('drivers/v3d')
+else
+ driver_v3d = declare_dependency()
endif
if with_gallium_tegra
subdir('winsys/tegra/drm')