summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2015-11-22 02:46:45 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2015-11-22 02:46:45 +0000
commit0784c49c0f8fcc8b3abd4c9286d9fd8bc089dd7d (patch)
treea6394e3e264a0f80b57f4ce0f5d9526aa543d4b0 /lib/mesa/src/gallium/targets/opencl/Makefile.am
parentd91d0007eecf589ea5699e34aa4d748fce2c57b2 (diff)
import Mesa 11.0.6
Diffstat (limited to 'lib/mesa/src/gallium/targets/opencl/Makefile.am')
-rw-r--r--lib/mesa/src/gallium/targets/opencl/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/lib/mesa/src/gallium/targets/opencl/Makefile.am b/lib/mesa/src/gallium/targets/opencl/Makefile.am
new file mode 100644
index 000000000..c78b26832
--- /dev/null
+++ b/lib/mesa/src/gallium/targets/opencl/Makefile.am
@@ -0,0 +1,52 @@
+include $(top_srcdir)/src/gallium/Automake.inc
+
+lib_LTLIBRARIES = lib@OPENCL_LIBNAME@.la
+
+lib@OPENCL_LIBNAME@_la_LDFLAGS = \
+ $(LLVM_LDFLAGS) \
+ -no-undefined \
+ -version-number @OPENCL_VERSION@:0 \
+ $(GC_SECTIONS) \
+ $(LD_NO_UNDEFINED)
+
+if HAVE_LD_VERSION_SCRIPT
+lib@OPENCL_LIBNAME@_la_LDFLAGS += \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/opencl/opencl.sym
+endif
+
+lib@OPENCL_LIBNAME@_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader.la \
+ $(top_builddir)/src/gallium/state_trackers/clover/libclover.la \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ $(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
+ $(ELF_LIB) \
+ -ldl \
+ -lclangCodeGen \
+ -lclangFrontendTool \
+ -lclangFrontend \
+ -lclangDriver \
+ -lclangSerialization \
+ -lclangCodeGen \
+ -lclangParse \
+ -lclangSema \
+ -lclangAnalysis \
+ -lclangAST \
+ -lclangEdit \
+ -lclangLex \
+ -lclangBasic \
+ $(LLVM_LIBS) \
+ $(PTHREAD_LIBS)
+
+nodist_EXTRA_lib@OPENCL_LIBNAME@_la_SOURCES = dummy.cpp
+lib@OPENCL_LIBNAME@_la_SOURCES =
+
+EXTRA_lib@OPENCL_LIBNAME@_la_DEPENDENCIES = opencl.sym
+EXTRA_DIST = mesa.icd opencl.sym
+
+if HAVE_CLOVER_ICD
+icddir = /etc/OpenCL/vendors/
+icd_DATA = mesa.icd
+endif
+
+include $(top_srcdir)/install-gallium-links.mk