summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2015-12-23 13:27:37 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2015-12-23 13:27:37 +0000
commit5f7540fe56d9bd78811acbd834be64d07862b5a5 (patch)
treea88beb5592749f9418634348467950aeaf1f9d01 /lib/mesa/src/gallium/targets/opencl/Makefile.am
parent2f35ab22e92c7e0d9211cd62d9e57904c69940a0 (diff)
Import Mesa 11.0.8
This seems to fix some of the problems with clutter/gnome reported to occur on r600 with 11.0.6
Diffstat (limited to 'lib/mesa/src/gallium/targets/opencl/Makefile.am')
-rw-r--r--lib/mesa/src/gallium/targets/opencl/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/lib/mesa/src/gallium/targets/opencl/Makefile.am b/lib/mesa/src/gallium/targets/opencl/Makefile.am
index c78b26832..93b4d3a83 100644
--- a/lib/mesa/src/gallium/targets/opencl/Makefile.am
+++ b/lib/mesa/src/gallium/targets/opencl/Makefile.am
@@ -2,6 +2,9 @@ include $(top_srcdir)/src/gallium/Automake.inc
lib_LTLIBRARIES = lib@OPENCL_LIBNAME@.la
+AM_CPPFLAGS = \
+ $(LIBELF_CFLAGS)
+
lib@OPENCL_LIBNAME@_la_LDFLAGS = \
$(LLVM_LDFLAGS) \
-no-undefined \
@@ -20,8 +23,8 @@ lib@OPENCL_LIBNAME@_la_LIBADD = \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \
$(top_builddir)/src/util/libmesautil.la \
$(GALLIUM_PIPE_LOADER_WINSYS_LIBS) \
- $(ELF_LIB) \
- -ldl \
+ $(LIBELF_LIBS) \
+ $(DLOPEN_LIBS) \
-lclangCodeGen \
-lclangFrontendTool \
-lclangFrontend \