summaryrefslogtreecommitdiff
path: root/lib/mesa/src/gallium/targets/opencl/Makefile.am
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2020-01-22 03:03:07 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2020-01-22 03:03:07 +0000
commita2addd175959cb3aeed913a723c4494a04135ca9 (patch)
tree861beaf09d2707f5950be01e90fcaa035b4afd92 /lib/mesa/src/gallium/targets/opencl/Makefile.am
parent7b575d15a3a74fc8e01d2df0cd88d7d432bbd6d4 (diff)
add back autotools files removed upstream
Diffstat (limited to 'lib/mesa/src/gallium/targets/opencl/Makefile.am')
-rw-r--r--lib/mesa/src/gallium/targets/opencl/Makefile.am51
1 files changed, 51 insertions, 0 deletions
diff --git a/lib/mesa/src/gallium/targets/opencl/Makefile.am b/lib/mesa/src/gallium/targets/opencl/Makefile.am
new file mode 100644
index 000000000..f0e1de779
--- /dev/null
+++ b/lib/mesa/src/gallium/targets/opencl/Makefile.am
@@ -0,0 +1,51 @@
+include $(top_srcdir)/src/gallium/Automake.inc
+
+lib_LTLIBRARIES = lib@OPENCL_LIBNAME@.la
+
+lib@OPENCL_LIBNAME@_la_LDFLAGS = \
+ $(LLVM_LDFLAGS) \
+ -no-undefined \
+ -version-number @OPENCL_VERSION@:0 \
+ $(GC_SECTIONS) \
+ $(LD_NO_UNDEFINED)
+
+if HAVE_LD_VERSION_SCRIPT
+lib@OPENCL_LIBNAME@_la_LDFLAGS += \
+ -Wl,--version-script=$(top_srcdir)/src/gallium/targets/opencl/opencl.sym
+endif
+
+lib@OPENCL_LIBNAME@_la_LIBADD = \
+ $(top_builddir)/src/gallium/auxiliary/pipe-loader/libpipe_loader_dynamic.la \
+ $(top_builddir)/src/gallium/state_trackers/clover/libclover.la \
+ $(top_builddir)/src/gallium/auxiliary/libgallium.la \
+ $(top_builddir)/src/util/libmesautil.la \
+ $(EXPAT_LIBS) \
+ $(LIBELF_LIBS) \
+ $(DLOPEN_LIBS) \
+ -lclangCodeGen \
+ -lclangFrontend \
+ -lclangFrontendTool \
+ -lclangDriver \
+ -lclangSerialization \
+ -lclangParse \
+ -lclangSema \
+ -lclangAnalysis \
+ -lclangAST \
+ -lclangEdit \
+ -lclangLex \
+ -lclangBasic \
+ $(LLVM_LIBS) \
+ $(PTHREAD_LIBS)
+
+nodist_EXTRA_lib@OPENCL_LIBNAME@_la_SOURCES = dummy.cpp
+lib@OPENCL_LIBNAME@_la_SOURCES =
+
+EXTRA_lib@OPENCL_LIBNAME@_la_DEPENDENCIES = opencl.sym
+EXTRA_DIST = mesa.icd opencl.sym meson.build
+
+if HAVE_CLOVER_ICD
+icddir = $(sysconfdir)/OpenCL/vendors/
+icd_DATA = mesa.icd
+endif
+
+include $(top_srcdir)/install-gallium-links.mk