summaryrefslogtreecommitdiff
path: root/lib/mesa/src/glx/meson.build
diff options
context:
space:
mode:
authorJonathan Gray <jsg@cvs.openbsd.org>2020-09-22 02:09:17 +0000
committerJonathan Gray <jsg@cvs.openbsd.org>2020-09-22 02:09:17 +0000
commit865c23c9c56f47f6cf8d73e8a6060a0c33a28b93 (patch)
treeaeed22bc39ce87dd6f09ff173c8273beaef65fe7 /lib/mesa/src/glx/meson.build
parent27e7bb02bd0f89f96d9e3b402b46c2c97ee4defe (diff)
Merge Mesa 20.0.8
With Mesa 20.1 even after the kernel change to do wbinvd on all cpus sthen@ reported that hard hangs still occurred on his Haswell system with inteldrm. Mark Kane also reported seeing hangs on Ivy Bridge on bugs@. Some systems/workloads seem to be more prone to triggering this than others as I have not seen any hangs on Ivy Bridge and the only hangs I saw on Haswell when running piglit went away with the wbinvd change. It seems something is wrong with drm memory attributes or coherency in the kernel and newer Mesa versions expect behaviour we don't have.
Diffstat (limited to 'lib/mesa/src/glx/meson.build')
-rw-r--r--lib/mesa/src/glx/meson.build23
1 files changed, 14 insertions, 9 deletions
diff --git a/lib/mesa/src/glx/meson.build b/lib/mesa/src/glx/meson.build
index 91fdf5d26..caa7127d6 100644
--- a/lib/mesa/src/glx/meson.build
+++ b/lib/mesa/src/glx/meson.build
@@ -30,12 +30,6 @@ files_libglx = files(
'clientinfo.c',
'compsize.c',
'create_context.c',
- 'dri_common.c',
- 'dri_common.h',
- 'dri_common_query_renderer.c',
- 'dri_common_interop.c',
- 'drisw_glx.c',
- 'drisw_priv.h',
'eval.c',
'glxclient.h',
'glxcmds.c',
@@ -70,15 +64,26 @@ files_libglx = files(
'single2.c',
'singlepix.c',
'vertarr.c',
- 'xfont.c',
)
extra_libs_libglx = []
extra_deps_libgl = []
extra_ld_args_libgl = []
+if with_glx == 'dri'
+ files_libglx += files(
+ 'dri_common.c',
+ 'dri_common.h',
+ 'dri_common_query_renderer.c',
+ 'dri_common_interop.c',
+ 'xfont.c',
+ 'drisw_glx.c',
+ 'drisw_priv.h',
+ )
+endif
+
# dri2
-if with_dri_platform == 'drm' and dep_libdrm.found()
+if with_glx == 'dri' and with_dri_platform == 'drm' and dep_libdrm.found()
files_libglx += files(
'dri2.c',
'dri2_glx.c',
@@ -144,7 +149,7 @@ endif
libglx = static_library(
'glx',
[files_libglx, glx_generated],
- include_directories : [inc_include, inc_src, inc_mapi, inc_mesa, inc_gallium, inc_gallium_aux, inc_glapi, inc_loader],
+ include_directories : [inc_common, inc_glapi, inc_loader],
c_args : [
c_vis_args, gl_lib_cargs, gl_lib_define,
],