summaryrefslogtreecommitdiff
path: root/lib/xcb-util-keysyms/keysyms/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2014-04-14 19:30:25 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2014-04-14 19:30:25 +0000
commit053af2c08935866b4efa0c92d40967f80a3bb23a (patch)
treef4dc97fd278036754c050fcac472d80413b73b55 /lib/xcb-util-keysyms/keysyms/Makefile.am
parent1f0e0b108ac20bc9be0478f7a4cdbf85a197de50 (diff)
Import xcb-util-keysyms 0.3.9
Diffstat (limited to 'lib/xcb-util-keysyms/keysyms/Makefile.am')
-rw-r--r--lib/xcb-util-keysyms/keysyms/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/lib/xcb-util-keysyms/keysyms/Makefile.am b/lib/xcb-util-keysyms/keysyms/Makefile.am
new file mode 100644
index 000000000..79e8cafae
--- /dev/null
+++ b/lib/xcb-util-keysyms/keysyms/Makefile.am
@@ -0,0 +1,17 @@
+
+MAINTAINERCLEANFILES = Makefile.in
+
+lib_LTLIBRARIES = libxcb-keysyms.la
+
+xcbinclude_HEADERS = xcb_keysyms.h
+
+AM_CFLAGS = $(CWARNFLAGS)
+
+libxcb_keysyms_la_SOURCES = keysyms.c
+libxcb_keysyms_la_CPPFLAGS = $(XCB_CFLAGS)
+libxcb_keysyms_la_LIBADD = $(XCB_LIBS)
+libxcb_keysyms_la_LDFLAGS = -version-info 1:0:0 -no-undefined
+
+pkgconfig_DATA = xcb-keysyms.pc
+
+EXTRA_DIST=xcb-keysyms.pc.in