summaryrefslogtreecommitdiff
path: root/util/gccmakedep/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:16:48 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2006-11-25 16:16:48 +0000
commit3f58440c73fee49a1cbf3a9f47ba06592f33208b (patch)
tree1a39da9e217885b74c9c0f09e6431bb66a2c0a32 /util/gccmakedep/Makefile.am
parent7b467928c509058d60342a08c51c85693cdfa281 (diff)
import from X.Org 7.2RC2
Diffstat (limited to 'util/gccmakedep/Makefile.am')
-rw-r--r--util/gccmakedep/Makefile.am60
1 files changed, 60 insertions, 0 deletions
diff --git a/util/gccmakedep/Makefile.am b/util/gccmakedep/Makefile.am
new file mode 100644
index 000000000..c6ed3d781
--- /dev/null
+++ b/util/gccmakedep/Makefile.am
@@ -0,0 +1,60 @@
+#
+# Copyright 2005 Red Hat, Inc.
+#
+# Permission to use, copy, modify, distribute, and sell this software and its
+# documentation for any purpose is hereby granted without fee, provided that
+# the above copyright notice appear in all copies and that both that
+# copyright notice and this permission notice appear in supporting
+# documentation, and that the name of Red Hat not be used in
+# advertising or publicity pertaining to distribution of the software without
+# specific, written prior permission. Red Hat makes no
+# representations about the suitability of this software for any purpose. It
+# is provided "as is" without express or implied warranty.
+#
+# RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
+# INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
+# EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
+# CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE,
+# DATA OR PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER
+# TORTIOUS ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR
+# PERFORMANCE OF THIS SOFTWARE.
+
+gccmakedep_DATA = gccmakedep
+gccmakedepdir = $(bindir)
+
+include cpprules.in
+
+DEFS = \
+ -DCCCMD=$(CC)\
+ -DRMCMD='"rm -f"'\
+ -DLNCMD="ln"\
+ -DMVCMD="mv"
+
+CPP_FILES_FLAGS = $(DEFS)
+
+gccmakedep: gccmdep
+ cp gccmdep gccmakedep
+install-data-hook:
+ chmod +x $(DESTDIR)/$(bindir)/gccmakedep
+
+appmandir = $(APP_MAN_DIR)
+
+appman_PRE = gccmakedep.man
+
+appman_DATA = $(appman_PRE:man=@APP_MAN_SUFFIX@)
+
+CLEANFILES = $(appman_DATA) gccmakedep gccmdep
+
+# Strings to replace in man pages
+XORGRELSTRING = @PACKAGE_STRING@
+ XORGMANNAME = X Version 11
+
+MAN_SUBSTS = \
+ -e 's|__vendorversion__|"$(XORGRELSTRING)" "$(XORGMANNAME)"|'
+
+SUFFIXES += .$(APP_MAN_SUFFIX) .man
+
+.man.$(APP_MAN_SUFFIX):
+ sed $(MAN_SUBSTS) < $< > $@
+
+EXTRA_DIST = $(appman_PRE) gccmdep.cpp