summaryrefslogtreecommitdiff
path: root/xserver/mi/Makefile.am
diff options
context:
space:
mode:
authorMatthieu Herrb <matthieu@cvs.openbsd.org>2010-07-27 19:02:39 +0000
committerMatthieu Herrb <matthieu@cvs.openbsd.org>2010-07-27 19:02:39 +0000
commit269d40cbcc43b41f621ca6d91c182952f60ec48e (patch)
tree872f2fddd3f2207e57a28595e73886713ce4a77a /xserver/mi/Makefile.am
parent917a2249b787451cad3f9697872aeccfd0da3324 (diff)
Update to xserver 1.8. Tested by many. Ok oga@, todd@.
Diffstat (limited to 'xserver/mi/Makefile.am')
-rw-r--r--xserver/mi/Makefile.am14
1 files changed, 4 insertions, 10 deletions
diff --git a/xserver/mi/Makefile.am b/xserver/mi/Makefile.am
index 42f75ae73..9714a21ca 100644
--- a/xserver/mi/Makefile.am
+++ b/xserver/mi/Makefile.am
@@ -1,16 +1,14 @@
-noinst_LTLIBRARIES = libminimi.la libmi.la
+noinst_LTLIBRARIES = libmi.la
if XORG
sdk_HEADERS = mibank.h micmap.h miline.h mipointer.h mi.h mibstore.h \
migc.h mipointrst.h mizerarc.h micoord.h mifillarc.h \
- mispans.h miwideline.h mistruct.h mifpoly.h
+ mispans.h miwideline.h mistruct.h mifpoly.h mioverlay.h
endif
AM_CFLAGS = $(DIX_CFLAGS)
-# libminimi is for dmx - it has different defines for miinitext.c
-libminimi_la_SOURCES = \
- cbrt.c \
+libmi_la_SOURCES = \
mi.h \
miarc.c \
mibank.c \
@@ -22,6 +20,7 @@ libminimi_la_SOURCES = \
micmap.c \
micmap.h \
micoord.h \
+ micopy.c \
micursor.c \
midash.c \
midispcur.c \
@@ -58,7 +57,6 @@ libminimi_la_SOURCES = \
mispans.h \
misprite.c \
misprite.h \
- mispritest.h \
mistruct.h \
mivaltree.c \
mivalidate.h \
@@ -69,7 +67,3 @@ libminimi_la_SOURCES = \
mizerarc.h \
mizerclip.c \
mizerline.c
-
-libmi_la_SOURCES = $(libminimi_la_SOURCES)
-
-INCLUDES = -I$(top_srcdir)/mfb