summaryrefslogtreecommitdiff
path: root/app/x11perf/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/x11perf/configure.ac')
-rw-r--r--app/x11perf/configure.ac17
1 files changed, 10 insertions, 7 deletions
diff --git a/app/x11perf/configure.ac b/app/x11perf/configure.ac
index d5f744760..ed3c90552 100644
--- a/app/x11perf/configure.ac
+++ b/app/x11perf/configure.ac
@@ -1,5 +1,5 @@
dnl Copyright 2005 Red Hat, Inc.
-dnl
+dnl
dnl Permission to use, copy, modify, distribute, and sell this software and its
dnl documentation for any purpose is hereby granted without fee, provided that
dnl the above copyright notice appear in all copies and that both that
@@ -9,7 +9,7 @@ dnl advertising or publicity pertaining to distribution of the software without
dnl specific, written prior permission. Red Hat makes no
dnl representations about the suitability of this software for any purpose. It
dnl is provided "as is" without express or implied warranty.
-dnl
+dnl
dnl RED HAT DISCLAIMS ALL WARRANTIES WITH REGARD TO THIS SOFTWARE,
dnl INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO
dnl EVENT SHALL RED HAT BE LIABLE FOR ANY SPECIAL, INDIRECT OR
@@ -23,7 +23,7 @@ dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
AC_INIT([x11perf],
- [1.6.2],
+ [1.7.0],
[https://gitlab.freedesktop.org/xorg/test/x11perf/-/issues],
[x11perf])
AC_CONFIG_SRCDIR([Makefile.am])
@@ -39,13 +39,13 @@ XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
# Define the installation directory for the x11 performance compare scripts
-AC_SUBST([x11perfcompdir], [$libdir/X11/x11perfcomp])
+AC_SUBST([x11perfcompdir], [$datadir/X11/x11perfcomp])
# Checks for programs run by the scripts we install
AC_PATH_PROG(MKTEMP, mktemp)
# Checks for pkg-config packages
-PKG_CHECK_MODULES(X11PERF, [x11 xmuu xproto >= 7.0.17])
+PKG_CHECK_MODULES(X11PERF, [x11 xmuu xproto >= 7.0.25])
# Check for Xrender library
PKG_CHECK_MODULES(XRENDER, xrender, [xrender_found=yes], [xrender_found=no])
@@ -56,7 +56,7 @@ yes)
esac
# Check for Xft library
-PKG_CHECK_MODULES(XFT, xft, [xft_found=yes], [xft_found=no])
+PKG_CHECK_MODULES(XFT, xft fontconfig, [xft_found=yes], [xft_found=no])
case "$xft_found" in
yes)
AC_DEFINE(XFT,1,[Xft library available])
@@ -69,13 +69,16 @@ case "$xext_found" in
yes)
save_LIBS="$LIBS"
LIBS="$XEXT_LIBS $LIBS"
- AC_CHECK_FUNCS([XShmQueryExtension],
+ AC_CHECK_FUNCS([XShmQueryExtension],
AC_DEFINE(MITSHM, 1, [MIT-SHM extension available]))
LIBS="$save_LIBS"
;;
esac
AC_CHECK_FUNCS([srand_deterministic])
+AC_CONFIG_FILES([man/x11perf.1:man/x11perf.man])
+AC_CONFIG_FILES([man/x11perfcomp.1:man/x11perfcomp.man])
+AC_CONFIG_FILES([man/Xmark.1:man/Xmark.man])
AC_CONFIG_FILES([
Makefile