summaryrefslogtreecommitdiff
path: root/app/xlsfonts/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'app/xlsfonts/configure.ac')
-rw-r--r--app/xlsfonts/configure.ac11
1 files changed, 9 insertions, 2 deletions
diff --git a/app/xlsfonts/configure.ac b/app/xlsfonts/configure.ac
index f70eab399..c0e1eff74 100644
--- a/app/xlsfonts/configure.ac
+++ b/app/xlsfonts/configure.ac
@@ -23,10 +23,11 @@ dnl Process this file with autoconf to create configure.
# Initialize Autoconf
AC_PREREQ([2.60])
-AC_INIT(xlsfonts, [1.0.7],
- [https://gitlab.freedesktop.org/xorg/app/xlsfonts/issues],xlsfonts)
+AC_INIT(xlsfonts, [1.0.8],
+ [https://gitlab.freedesktop.org/xorg/app/xlsfonts/-/issues],xlsfonts)
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_HEADERS([config.h])
+AC_USE_SYSTEM_EXTENSIONS
# Initialize Automake
AM_INIT_AUTOMAKE([foreign dist-xz])
@@ -40,6 +41,12 @@ XORG_DEFAULT_OPTIONS
# Checks for pkg-config packages
PKG_CHECK_MODULES(XLSFONTS, [x11 xproto >= 7.0.17])
+# Checks for library functions
+AC_SEARCH_LIBS([reallocarray], [bsd])
+AS_IF([test "x$ac_cv_search_reallocarray" = "x-lbsd"],
+ [AC_CHECK_HEADERS([bsd/stdlib.h])])
+AC_CHECK_FUNCS([reallocarray])
+
AC_CONFIG_FILES([
Makefile
man/Makefile])