summaryrefslogtreecommitdiff
path: root/driver/xf86-input-citron/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'driver/xf86-input-citron/Makefile.am')
-rw-r--r--driver/xf86-input-citron/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/driver/xf86-input-citron/Makefile.am b/driver/xf86-input-citron/Makefile.am
index 7052905f3..891219898 100644
--- a/driver/xf86-input-citron/Makefile.am
+++ b/driver/xf86-input-citron/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright 2005 Adam Jackson.
+# $Id: Makefile.am,v 1.2 2008/08/23 13:05:44 matthieu Exp $
#
# Permission is hereby granted, free of charge, to any person obtaining a
# copy of this software and associated documentation files (the "Software"),
@@ -20,3 +20,11 @@
AUTOMAKE_OPTIONS = foreign
SUBDIRS = src man
+
+CLEANFILES = ChangeLog
+EXTRA_DIST = ChangeLog
+
+.PHONY: ChangeLog
+
+ChangeLog:
+ (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)