summaryrefslogtreecommitdiff
path: root/driver/xf86-video-apm/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'driver/xf86-video-apm/src/Makefile.am')
-rw-r--r--driver/xf86-video-apm/src/Makefile.am10
1 files changed, 4 insertions, 6 deletions
diff --git a/driver/xf86-video-apm/src/Makefile.am b/driver/xf86-video-apm/src/Makefile.am
index 8a6779e28..ad26a0c23 100644
--- a/driver/xf86-video-apm/src/Makefile.am
+++ b/driver/xf86-video-apm/src/Makefile.am
@@ -24,6 +24,9 @@
# -avoid-version prevents gratuitous .0.0.0 version numbers on the end
# _ladir passes a dummy rpath to libtool so the thing will actually link
# TODO: -nostdlib/-Bstatic/-lgcc platform magic, not installing the .a, etc.
+
+AM_CFLAGS = $(XORG_CFLAGS) $(PCIACCESS_CFLAGS)
+
apm_drv_la_LTLIBRARIES = apm_drv.la
apm_drv_la_LDFLAGS = -module -avoid-version
apm_drv_ladir = @moduledir@/drivers
@@ -38,11 +41,6 @@ apm_drv_la_SOURCES = \
apm_regs.h \
apm_pcirename.h
-if XF86RUSH
-apm_drv_la_SOURCES += apm_rush.c
-endif
-
EXTRA_DIST = \
apm_funcs.c \
- apm_video.c \
- apm_rush.c
+ apm_video.c