summaryrefslogtreecommitdiff
path: root/lib/libXv/man/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/libXv/man/Makefile.am')
-rw-r--r--lib/libXv/man/Makefile.am113
1 files changed, 49 insertions, 64 deletions
diff --git a/lib/libXv/man/Makefile.am b/lib/libXv/man/Makefile.am
index 0e76d72f6..0041a7895 100644
--- a/lib/libXv/man/Makefile.am
+++ b/lib/libXv/man/Makefile.am
@@ -1,80 +1,65 @@
# $Xorg: Makefile.am,v 1.1.1.1 2006/11/25 18:04:55 matthieu Exp $
#
-# Copyright 2005 Sun Microsystems, Inc. All rights reserved.
-#
-# Permission to use, copy, modify, distribute, and sell this software and its
-# documentation for any purpose is hereby granted without fee, provided that
-# the above copyright notice appear in all copies and that both that
-# copyright notice and this permission notice appear in supporting
-# documentation.
-#
-# The above copyright notice and this permission notice shall be included
-# in all copies or substantial portions of the Software.
-#
-# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS
-# OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
-# MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT.
-# IN NO EVENT SHALL THE OPEN GROUP BE LIABLE FOR ANY CLAIM, DAMAGES OR
-# OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE,
-# ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
-# OTHER DEALINGS IN THE SOFTWARE.
-#
-# Except as contained in this notice, the name of the copyright holders shall
-# not be used in advertising or otherwise to promote the sale, use or
-# other dealings in this Software without prior written authorization
-# from the copyright holders.
-#
+# Copyright (c) 2005, Oracle and/or its affiliates. All rights reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# the rights to use, copy, modify, merge, publish, distribute, sublicense,
+# and/or sell copies of the Software, and to permit persons to whom the
+# Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
+# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
+# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+# DEALINGS IN THE SOFTWARE.
+#
libmandir = $(LIB_MAN_DIR)
-libman_PRE = \
- Xv.man \
- XvCreateImage.man \
- XvFreeAdaptorInfo.man \
- XvFreeEncodingInfo.man \
- XvGetPortAttribute.man \
- XvGetStill.man \
- XvGetVideo.man \
- XvGrabPort.man \
- XvListImageFormats.man \
- XvPortNotify.man \
- XvPutImage.man \
- XvPutStill.man \
- XvPutVideo.man \
- XvQueryAdaptors.man \
- XvQueryBestSize.man \
- XvQueryEncodings.man \
- XvQueryExtension.man \
- XvQueryPortAttributes.man \
- XvSelectPortNotify.man \
- XvSelectVideoNotify.man \
- XvSetPortAttribute.man \
- XvShmCreateImage.man \
- XvShmPutImage.man \
- XvStopVideo.man \
- XvUngrabPort.man \
- XvVideoNotify.man
+libman_PRE = \
+ Xv.man \
+ XvCreateImage.man \
+ XvFreeAdaptorInfo.man \
+ XvFreeEncodingInfo.man \
+ XvGetPortAttribute.man \
+ XvGetStill.man \
+ XvGetVideo.man \
+ XvGrabPort.man \
+ XvListImageFormats.man \
+ XvPortNotify.man \
+ XvPutImage.man \
+ XvPutStill.man \
+ XvPutVideo.man \
+ XvQueryAdaptors.man \
+ XvQueryBestSize.man \
+ XvQueryEncodings.man \
+ XvQueryExtension.man \
+ XvQueryPortAttributes.man \
+ XvSelectPortNotify.man \
+ XvSelectVideoNotify.man \
+ XvSetPortAttribute.man \
+ XvShmCreateImage.man \
+ XvShmPutImage.man \
+ XvStopVideo.man \
+ XvUngrabPort.man \
+ XvVideoNotify.man
libman_DATA = $(libman_PRE:man=@LIB_MAN_SUFFIX@)
-LIB_MAN_DIR_SUFFIX = $(LIB_MAN_DIR:@mandir@/man%=%)
-
EXTRA_DIST = $(libman_PRE) xv-library-v2.2.txt
CLEANFILES = $(libman_DATA)
-SED = sed
-
-# Strings to replace in man pages
-XORGRELSTRING = @PACKAGE_STRING@
- XORGMANNAME = X Version 11
-
-MAN_SUBSTS = \
- -e 's/__vendorversion__/"$(XORGRELSTRING)" "$(XORGMANNAME)"/' \
- -e 's/__libmandirsuffix__/$(LIB_MAN_DIR_SUFFIX)/g' \
- -e 's/__libmansuffix__/$(LIB_MAN_SUFFIX)/g'
-
SUFFIXES = .$(LIB_MAN_SUFFIX) .man
+# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
.man.$(LIB_MAN_SUFFIX):
$(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@