summaryrefslogtreecommitdiff
path: root/lib/mesa/src/compiler/glsl/glcpp/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mesa/src/compiler/glsl/glcpp/meson.build')
-rw-r--r--lib/mesa/src/compiler/glsl/glcpp/meson.build75
1 files changed, 75 insertions, 0 deletions
diff --git a/lib/mesa/src/compiler/glsl/glcpp/meson.build b/lib/mesa/src/compiler/glsl/glcpp/meson.build
new file mode 100644
index 000000000..a03d589b3
--- /dev/null
+++ b/lib/mesa/src/compiler/glsl/glcpp/meson.build
@@ -0,0 +1,75 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+glcpp_parse = custom_target(
+ 'glcpp-parse.[ch]',
+ input : 'glcpp-parse.y',
+ output : ['glcpp-parse.c', 'glcpp-parse.h'],
+ command : [
+ prog_bison, '-o', '@OUTPUT0@', '-p', 'glcpp_parser_',
+ '--defines=@OUTPUT1@', '@INPUT@',
+ ],
+)
+
+glcpp_lex = custom_target(
+ 'glcpp-lex.c',
+ input : 'glcpp-lex.l',
+ output : 'glcpp-lex.c',
+ command : [prog_flex, '-o', '@OUTPUT@', '@INPUT@'],
+)
+
+libglcpp = static_library(
+ 'glcpp',
+ [glcpp_lex, glcpp_parse, files('glcpp.h', 'pp.c')],
+ link_with : libmesa_util,
+ include_directories : [inc_common],
+ c_args : [c_vis_args, no_override_init_args, c_msvc_compat_args],
+ cpp_args : [cpp_vis_args, cpp_msvc_compat_args],
+ build_by_default : false,
+)
+
+glcpp = executable(
+ 'glcpp',
+ 'glcpp.c',
+ dependencies : [dep_m],
+ include_directories : [inc_common],
+ link_with : [libglcpp, libglsl_util],
+ c_args : [c_vis_args, no_override_init_args, c_msvc_compat_args],
+ build_by_default : false,
+)
+
+if with_any_opengl and with_tests
+ modes = ['unix', 'windows', 'oldmac', 'bizarro']
+ if dep_valgrind.found()
+ modes += ['valgrind']
+ endif
+
+ foreach m : modes
+ test(
+ 'glcpp test (@0@)'.format(m),
+ prog_python,
+ args : [
+ join_paths(meson.current_source_dir(), 'tests/glcpp_test.py'),
+ glcpp, join_paths(meson.current_source_dir(), 'tests'),
+ '--@0@'.format(m),
+ ],
+ )
+ endforeach
+endif