summaryrefslogtreecommitdiff
path: root/lib/mesa/src/glx/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mesa/src/glx/Makefile.am')
-rw-r--r--lib/mesa/src/glx/Makefile.am5
1 files changed, 1 insertions, 4 deletions
diff --git a/lib/mesa/src/glx/Makefile.am b/lib/mesa/src/glx/Makefile.am
index 0d6c3eb0f..df0acdc30 100644
--- a/lib/mesa/src/glx/Makefile.am
+++ b/lib/mesa/src/glx/Makefile.am
@@ -155,7 +155,7 @@ libglx_la_LIBADD += \
$(builddir)/windows/libwindowsglx.la
endif
-if USE_LIBGLVND
+if USE_LIBGLVND_GLX
AM_CFLAGS += \
-DGL_LIB_NAME=\"lib@GL_LIB@.so\" \
$(GLVND_CFLAGS)
@@ -174,10 +174,7 @@ AM_CFLAGS += \
GL_LIB_VERSION=1:2
endif
-# Push the libdrm furhter up, as due to libtool bug we might end up relinking
-# against the system one.
GL_LIBS = \
- $(LIBDRM_LIBS) \
libglx.la \
$(top_builddir)/src/mapi/glapi/libglapi.la \
$(SHARED_GLAPI_LIB) \