summaryrefslogtreecommitdiff
path: root/lib/mesa/src/util/tests/hash_table/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mesa/src/util/tests/hash_table/meson.build')
-rw-r--r--lib/mesa/src/util/tests/hash_table/meson.build35
1 files changed, 35 insertions, 0 deletions
diff --git a/lib/mesa/src/util/tests/hash_table/meson.build b/lib/mesa/src/util/tests/hash_table/meson.build
new file mode 100644
index 000000000..c7b03f19c
--- /dev/null
+++ b/lib/mesa/src/util/tests/hash_table/meson.build
@@ -0,0 +1,35 @@
+# Copyright © 2017 Intel Corporation
+
+# Permission is hereby granted, free of charge, to any person obtaining a copy
+# of this software and associated documentation files (the "Software"), to deal
+# in the Software without restriction, including without limitation the rights
+# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+# copies of the Software, and to permit persons to whom the Software is
+# furnished to do so, subject to the following conditions:
+
+# The above copyright notice and this permission notice shall be included in
+# all copies or substantial portions of the Software.
+
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+# SOFTWARE.
+
+foreach t : ['clear', 'collision', 'delete_and_lookup', 'delete_management',
+ 'destroy_callback', 'insert_and_lookup', 'insert_many',
+ 'null_destroy', 'random_entry', 'remove_key', 'remove_null',
+ 'replacement']
+ test(
+ t,
+ executable(
+ '@0@_test'.format(t),
+ files('@0@.c'.format(t)),
+ dependencies : [dep_thread, dep_dl],
+ include_directories : [inc_include, inc_util],
+ link_with : libmesa_util,
+ )
+ )
+endforeach