summaryrefslogtreecommitdiff
path: root/proto/inputproto/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'proto/inputproto/Makefile.am')
-rw-r--r--proto/inputproto/Makefile.am11
1 files changed, 6 insertions, 5 deletions
diff --git a/proto/inputproto/Makefile.am b/proto/inputproto/Makefile.am
index f8d4a3207..85ca02fac 100644
--- a/proto/inputproto/Makefile.am
+++ b/proto/inputproto/Makefile.am
@@ -1,20 +1,21 @@
inputdir = $(includedir)/X11/extensions
input_HEADERS = \
XI.h \
- XInput.h \
- XIproto.h
+ XIproto.h \
+ XI2.h \
+ XI2proto.h
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = inputproto.pc
-EXTRA_DIST = autogen.sh inputproto.pc.in
+EXTRA_DIST = inputproto.pc.in
-EXTRA_DIST += ChangeLog
+EXTRA_DIST += ChangeLog XI2proto.txt XIproto.txt
MAINTAINERCLEANFILES = ChangeLog
.PHONY: ChangeLog
ChangeLog:
- (GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog