summaryrefslogtreecommitdiff
path: root/util/imake/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'util/imake/configure.ac')
-rw-r--r--util/imake/configure.ac19
1 files changed, 7 insertions, 12 deletions
diff --git a/util/imake/configure.ac b/util/imake/configure.ac
index 78722d915..2083d29d9 100644
--- a/util/imake/configure.ac
+++ b/util/imake/configure.ac
@@ -21,30 +21,26 @@ dnl PERFORMANCE OF THIS SOFTWARE.
dnl
dnl Process this file with autoconf to create configure.
-AC_PREREQ([2.57])
-AC_INIT(imake, [1.0.3], [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg])
+AC_PREREQ([2.60])
+AC_INIT([imake], [1.0.4],
+ [https://bugs.freedesktop.org/enter_bug.cgi?product=xorg], [imake])
AM_INIT_AUTOMAKE([foreign dist-bzip2])
AM_MAINTAINER_MODE
AM_CONFIG_HEADER(config.h)
-# Require xorg-macros: XORG_DEFAULT_OPTIONS
+# Require X.Org macros 1.8 or later for MAN_SUBSTS set by XORG_MANPAGE_SECTIONS
m4_ifndef([XORG_MACROS_VERSION],
- [m4_fatal([must install xorg-macros 1.4 or later before running autoconf/autogen])])
-XORG_MACROS_VERSION(1.4)
+ [m4_fatal([must install xorg-macros 1.8 or later before running autoconf/autogen])])
+XORG_MACROS_VERSION(1.8)
XORG_DEFAULT_OPTIONS
-AC_PROG_CC
-AC_PROG_INSTALL
-
AC_PROG_CPP
-AC_PATH_PROG(SED, sed)
XORG_PROG_RAWCPP
CPP_PROGRAM=${RAWCPP}
AC_SUBST(CPP_PROGRAM)
-AC_CHECK_FUNC([mkstemp],
- AC_DEFINE(HAS_MKSTEMP,1,[Define to 1 if you have the "mkstemp" function.]))
+AC_CHECK_FUNCS([mkstemp])
AC_CHECK_PROG(HAS_PERL, perl, yes)
AM_CONDITIONAL([HAS_PERL], [test "x$HAS_PERL" = xyes])
@@ -129,6 +125,5 @@ AM_CONDITIONAL([BUILD_MKHTMLINDEX], [test "x$BUILD_MKHTMLINDEX" = xyes])
# Checks for pkg-config packages
PKG_CHECK_MODULES(XPROTO, xproto)
-AC_SUBST(XPROTO_CFLAGS)
AC_OUTPUT([Makefile])