summaryrefslogtreecommitdiff
path: root/xserver/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'xserver/Makefile.am')
-rw-r--r--xserver/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/xserver/Makefile.am b/xserver/Makefile.am
index 9a628537d..5bf760b2e 100644
--- a/xserver/Makefile.am
+++ b/xserver/Makefile.am
@@ -17,6 +17,14 @@ if RECORD
RECORD_DIR=record
endif
+if DRI3
+DRI3_DIR=dri3
+endif
+
+if PRESENT
+PRESENT_DIR=present
+endif
+
SUBDIRS = \
doc \
man \
@@ -27,6 +35,7 @@ SUBDIRS = \
Xext \
miext \
os \
+ pseudoramiX \
randr \
render \
Xi \
@@ -37,6 +46,8 @@ SUBDIRS = \
damageext \
$(COMPOSITE_DIR) \
$(GLX_DIR) \
+ $(PRESENT_DIR) \
+ $(DRI3_DIR) \
exa \
config \
hw \
@@ -77,6 +88,7 @@ DIST_SUBDIRS = \
Xext \
miext \
os \
+ pseudoramiX \
randr \
render \
Xi \
@@ -89,6 +101,8 @@ DIST_SUBDIRS = \
glx \
exa \
config \
+ dri3 \
+ present \
hw \
test