summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChase Douglas <chase.douglas@canonical.com>2012-01-19 13:05:48 -0800
committerPeter Hutterer <peter.hutterer@who-t.net>2012-01-26 15:51:24 +1000
commitb1b9745979babd480574b41af155dfe5c06591f8 (patch)
tree42796a26ae3981b0b3e00bb0a8606fb0052d7959 /configure.ac
parent56d32619b95eb472104068c35ea7146dccb8d1bf (diff)
eventcomm: Initialize touch device and axes
Use mtdev to ensure touches are tracked and of evdev MT protocol type B. Signed-off-by: Chase Douglas <chase.douglas@canonical.com> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f8c7259..62f6ace 100644
--- a/configure.ac
+++ b/configure.ac
@@ -121,6 +121,14 @@ case "${host}" in
esac
if test "x$BUILD_EVENTCOMM" = xyes; then
AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
+
+ if test "x$HAVE_XI22" = xyes; then
+ # Obtain compiler/linker options for mtdev
+ PKG_CHECK_MODULES(MTDEV, mtdev, HAVE_MTDEV="yes", HAVE_MTDEV="no")
+ fi
+ if test "x$HAVE_XI22" = xyes && test "x$HAVE_MTDEV" = xyes; then
+ AC_DEFINE(HAVE_MTDEV, 1, [MTDev available])
+ fi
fi
if test "x$BUILD_PSMCOMM" = xyes; then
AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])